Bug 184449 - Pressing the browser button on an Acer Aspire 3002LCi causes the current battery state indicator to appear
Summary: Pressing the browser button on an Acer Aspire 3002LCi causes the current batt...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-power-manager   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords: Desktop
Depends On:
Blocks: 183415
TreeView+ depends on / blocked
 
Reported: 2006-03-08 21:33 UTC by Suzanne Hillman
Modified: 2013-03-13 04:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-09 20:16:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Suzanne Hillman 2006-03-08 21:33:33 UTC
Description of problem:
Pressing the browser button on an Acer Aspire 3002LCi causes the current battery
state indicator (from libnotify, I believe) to appear. (It also starts the
browser, if appropriately assigned via the gnome-keybinding-properties tool.)

This is especially interesting as - before I pressed that button the first time
- libnotify was not telling me about the battery state change when I unplugged
or plugged the AC power in, but does now.

Version-Release number of selected component (if applicable):
libnotify-0.3.0-5

How reproducible:
Always.

Steps to Reproduce:
1. Have FC5 installed on an Acer Aspire 3002LCi (we have one in Desktop QA)
2. Press the Browser button
  
Actual results:
A message from the battery indicator shows up, saying "Power Information.
Computer is running on AC power. Laptop battery fully charged (100%)" - likely
changes if one isn't on AC power, of course.

Expected results:
Should just call the associated action, if there is one, and not do anything
relating to the battery state.

Additional info:

Comment 1 John (J5) Palmieri 2006-03-08 21:51:09 UTC
Wierd. Most likely an event triggered by the button is being picked up by
gnome-power-manager.

Comment 2 Suzanne Hillman 2006-03-08 21:57:44 UTC
The button, at least according to the keyboard shortcuts screen after I
associated it with the browser, is 0xb2.

Comment 3 Richard Hughes 2006-03-08 22:01:32 UTC
By design, added by Ubuntu, in retrospect maybe a bad decision:

#define GPM_BUTTON_BRIGHT_UP		"brightness-up"
#define GPM_BUTTON_BRIGHT_DOWN		"brightness-down"
#define GPM_BUTTON_LOCK			"lock"
/* Using www until we get a better one defined for us by the kernel */
#define GPM_BUTTON_BATTERY		"www"

Got any ideas of a better key to use?

Comment 4 John (J5) Palmieri 2006-03-08 22:20:08 UTC
Ya, none by default.  It doesn't seem all that useful, in fact it seems like a
bug when a button does something that is totally unrelated.  "Lets make the big
smile face the one that launches the missles because we don't have a big red
button" :-).  We should export these options to the Keyboard Shortcuts capplet
and if someone wants to they would be able to assign "www" to GPM_BUTTON_BATTERY.

Comment 5 Richard Hughes 2006-03-22 11:24:32 UTC
2006-03-22  Richard Hughes  <richard@hughsie.com>
 * src/gpm-manager.c: Use the button "battery" rather than "www" to show the
battery status. This depends on mjg59's kernel addition and the use of a HAL
with the new button patched in.

Comment 6 Richard Hughes 2006-05-05 07:24:15 UTC
This should be fixed with yesterdays gnome-power-manager update, please confirm.

Comment 7 Suzanne Hillman 2006-08-09 20:16:51 UTC
Looks fixed, thanks!


Note You need to log in before you can comment on or make changes to this bug.