Bug 184459 - Automatic detection of the sound card did not work.
Automatic detection of the sound card did not work.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-08 17:41 EST by John Pylant
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 06:08:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
scsound log file (9.84 KB, text/plain)
2006-04-08 05:33 EDT, Roy Brichacek
no flags Details

  None (edit)
Description John Pylant 2006-03-08 17:41:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
Automatic detection of the sound card did not work.  Audio will not be available on the system.
You can inspect /root/scsound.log and file a new bug
at http://bugzilla.redhat.com.

Vendor: Intel
Model: Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller.
Module: snd-intel8x0


Version-Release number of selected component (if applicable):
2.6.15-1.1833_FC4

How reproducible:
Always

Steps to Reproduce:
1.Desktop
2.System Settings
3.Soundcard detection
  

Actual Results:  Window gives option to Play test sound. Nothing happens. When I reply to that effect, gives error about detection of sound card did not work.

Expected Results:  Play sound. Sound works with Windows and with Knoppix boot CD

Additional info:
Comment 1 Martin Stransky 2006-03-09 03:17:56 EST
Could you please attach /root/scsound.log?
Comment 2 John Pylant 2006-03-09 09:57:53 EST
(In reply to comment #1)
> Could you please attach /root/scsound.log?
/home/john/sound card detection
Copy of /root/scsound.log follows:

------- System Config Soundcard --------
Wed Feb  8 13:20:46 EST 2006

------- lspci --------
00:00.0 Host bridge: Intel Corporation 82875P/E7210 Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82875P Processor to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R)
AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200]
(rev a1)
02:08.0 Ethernet controller: Intel Corporation 82562EZ 10/100 Ethernet
Controller (rev 02)

------- lsmod --------
Module                  Size  Used by
parport_pc             27909  1 
lp                     12937  0 
parport                35593  2 parport_pc,lp
autofs4                19653  1 
rfcomm                 37461  0 
l2cap                  25153  5 rfcomm
bluetooth              47781  4 rfcomm,l2cap
sunrpc                146045  1 
ipt_REJECT              5953  1 
ipt_state               1985  1 
ip_conntrack           52717  1 ipt_state
nfnetlink               6617  1 ip_conntrack
iptable_filter          3137  1 
ip_tables              20033  3 ipt_REJECT,ipt_state,iptable_filter
video                  16197  0 
button                  6737  0 
battery                 9541  0 
ac                      4933  0 
ipv6                  252577  8 
usblp                  13633  0 
usb_storage            63241  0 
eepro100               30800  0 
uhci_hcd               32721  0 
ehci_hcd               33485  0 
hw_random               5589  0 
i2c_i801                9037  0 
i2c_core               21697  1 i2c_i801
snd_intel8x0           32093  1 
snd_ac97_codec         88161  1 snd_intel8x0
snd_ac97_bus            2497  1 snd_ac97_codec
snd_seq_dummy           3781  0 
snd_seq_oss            31809  0 
snd_seq_midi_event      7105  1 snd_seq_oss
snd_seq                49617  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          9037  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            50545  0 
snd_mixer_oss          17985  2 snd_pcm_oss
snd_pcm                86981  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              24901  2 snd_seq,snd_pcm
snd                    54309  9
snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9889  2 snd
snd_page_alloc         10697  2 snd_intel8x0,snd_pcm
e100                   39237  0 
mii                     5697  2 eepro100,e100
floppy                 62085  0 
dm_snapshot            17773  0 
dm_zero                 2113  0 
dm_mirror              22417  0 
ext3                  129993  2 
jbd                    57941  1 ext3
dm_mod                 56665  6 dm_snapshot,dm_zero,dm_mirror
ata_piix                9541  0 
libata                 56397  1 ata_piix
sd_mod                 19137  0 
scsi_mod              134889  3 usb_storage,libata,sd_mod

------- /etc/modprobe.conf --------
alias eth0 e100
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd

------- /etc/asound.conf --------
#Generated by system-config-soundcard, do not edit by hand
#SWCONF
#DEV 4
defaults.pcm.card 0 
defaults.pcm.device 4 
defaults.ctl.card 0 

------- aplay -l --------
**** List of PLAYBACK Hardware Devices ****
card 0: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: ICH5 [Intel ICH5], device 4: Intel ICH - IEC958 [Intel ICH5 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

------- amixer --------
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
Simple mixer control 'Master Mono',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 23 [74%] [on]
Simple mixer control 'Master Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
Simple mixer control 'Headphone Jack Sense',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
Simple mixer control 'Surround Jack Mode',0
  Capabilities: enum
  Items: 'Shared' 'Independent'
  Item0: 'Shared'
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 23 [74%] [on]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 23 [74%] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [on] Capture [off]
  Front Right: Playback 0 [0%] [on] Capture [off]
Simple mixer control 'Line Jack Sense',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on] Capture [on]
  Front Right: Playback 23 [74%] [on] Capture [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 0 [0%] [off]
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Mic Select',0
  Capabilities: enum
  Items: 'Mic1' 'Mic2'
  Item0: 'Mic1'
Simple mixer control 'Video',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Phone',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 0 [0%] [off]
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Aux',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [on] Capture [off]
  Front Right: Playback 0 [0%] [on] Capture [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 0 [0%] [off]
  Front Right: Capture 0 [0%] [off]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Mix Mono',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Channel Mode',0
  Capabilities: enum
  Items: '2ch' '4ch' '6ch'
  Item0: '2ch'
Simple mixer control 'Downmix',0
  Capabilities: enum
  Items: 'Off' '6 -> 4' '6 -> 2'
  Item0: 'Off'
Simple mixer control 'Exchange Front/Surround',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Spread Front to Surround and Center/LFE',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Stereo Mic',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]

------- /proc/asound/version --------
Advanced Linux Sound Architecture Driver Version 1.0.10rc3 (Mon Nov 07 13:30:21
2005 UTC).

------- /proc/asound/modules --------
0 snd_intel8x0

------- /proc/asound/pcm --------
00-00: Intel ICH : Intel ICH5 : playback 1 : capture 1
00-01: Intel ICH - MIC ADC : Intel ICH5 - MIC ADC : capture 1
00-02: Intel ICH - MIC2 ADC : Intel ICH5 - MIC2 ADC : capture 1
00-03: Intel ICH - ADC2 : Intel ICH5 - ADC2 : capture 1
00-04: Intel ICH - IEC958 : Intel ICH5 - IEC958 : playback 1

------- system-config-soundcard --------

/usr/share/system-config-soundcard/soundcard.py:174: DeprecationWarning: use
gtk.ComboBox
  self.primarySubDeviceOptionMenu = gtk.OptionMenu()
Card 0 Driver snd_intel8x0...
Unmuting ...
Play. Switch master(0) to 1
Play. Volume master(0) to 23
Play. Switch master(1) to 1
Play. Volume master(1) to 23
Play. Switch pcm(0) to 1
Play. Volume pcm(0) to 23
Play. Switch pcm(1) to 1
Play. Volume pcm(1) to 23
Cap. Switch cd(0) to 1
Play. Switch cd(0) to 1
Play. Volume cd(0) to 23
Cap. Switch cd(1) to 1
Play. Switch cd(1) to 1
Play. Volume cd(1) to 23
Cap. Switch mic(0) to 0
Play. Switch mic(0) to 0
Play. Volume mic(0) to 0
Cap. Switch mic(1) to 0
Unmuting snd_intel8x0...
Play. Switch master mono(0) to 1
Play. Volume master mono(0) to 23
Play. Switch external amplifier(0) to 1
Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16
bit Little Endian, Rate 44100 Hz, Stereo
Read config:
card 0
device 4
HW 0
----------- Kudzu -------------
Desc:           Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller
Driver:         snd-intel8x0
Device:         None

----------- **** -------------

Comment 3 Martin Stransky 2006-03-10 10:44:33 EST
Do you use the IEC958 device?
Comment 4 John Pylant 2006-03-10 12:54:06 EST
I don't know the answer to that. When I run the soundcard detection process, it
allows me to select default PCM device. Like the aplay dialog above, I have two
choices, ICH [Intel ICH5} or Intel ICH - IEC958 [Intel ICH5 - IEC958]. I have
tried both, and don't get sound with either. I have run Alsamixer (saw rerence
on web) to see if IEC958 showed up - it doesn't. I do have a PCM listed and made
sure that was unmuted. 
Comment 5 Martin Stransky 2006-03-13 09:24:43 EST
Hm, everything looks fine, could you check 1.0.10 drivers? how-to is here:
http://people.redhat.com/stransky/alsa

btw. I think you want to use "normal" device, i.e. ICH [Intel ICH5], IEC958 is a
digital output...
Comment 6 John Pylant 2006-03-15 17:41:23 EST
Martin,
I tried to check drivers, getting all the way to step 6, last step of your
process, naturally. rpmbuild --rebuild alsa-ut* gave series of warnings about
group komat not existing, using root. Then error: Failed build dependencies:
        gettext-devel is needed by alsa-utils-1.0.10-1.FC4.test.i386.
I tried rpm -i on gettext-devel-0.14.5.3.i386.rpm and that wanted tettext. Tried
rpm -i on gettext-0.14.5-3.i386.rpm and that gave error: Failed dependencies:
        libc.so.6(GLIBC_2.4) is needed by gettext-0.14.5-3.i386. Then did rpm
-iv glibc-2.4-4.src.rpm, which seemed to install glibc-2.4-4. Got same error on
rpm of gettext. I was guessing on several steps. Can you suggest various
packages if I used the wrong ones?

Thanks,

John 

Comment 7 Martin Stransky 2006-03-16 07:21:04 EST
alsa-utils isn't so important, you can use package which comes in FC4 update...
Comment 8 Roy Brichacek 2006-04-08 05:33:18 EDT
Created attachment 127500 [details]
scsound log file
Comment 9 Roy Brichacek 2006-04-08 05:35:06 EDT
Martin this problem has occured for me since upgrading from FC4 to FC5
Comment 10 Martin Stransky 2006-04-08 11:52:43 EDT
(In reply to comment #9)
> Martin this problem has occured for me since upgrading from FC4 to FC5

Your sound device looks busy. Could you check boot to console (or switch to
runlevel 3 with "#init 3" command) and run:

"$aplay /usr/share/sounds/phone.wav"?

Note You need to log in before you can comment on or make changes to this bug.