Bug 1844596 - [builds] Unable to build multi-stage image that has a --from=X that matches FROM X
Summary: [builds] Unable to build multi-stage image that has a --from=X that matches F...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard:
: 1843232 (view as bug list)
Depends On:
Blocks: 1845345
TreeView+ depends on / blocked
 
Reported: 2020-06-05 18:01 UTC by Adam Kaplan
Modified: 2020-10-27 16:05 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: buildah could not reference an image in `COPY --from` Dockerfile instructions Consequence: multistage Dockerfile builds with `COPY --from=<image>` instructions fail Fix: buildah updated to correctly use image references in `COPY --from` instructions Result: builds succeed
Clone Of: 1843232
Environment:
Last Closed: 2020-10-27 16:05:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift builder pull 160 0 None closed Bug 1844596: Bump buildah to v1.14.10 2021-01-19 15:09:36 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:05:53 UTC

Comment 8 Adam Kaplan 2020-08-19 21:05:36 UTC
*** Bug 1843232 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2020-10-27 16:05:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.