Bug 184482 - Banshee does not require ipod-sharp and libipoddevice
Banshee does not require ipod-sharp and libipoddevice
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 02:16 EST by Aaron Kurtz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.10.7-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 13:18:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Kurtz 2006-03-09 02:16:42 EST
Description of problem:
Thanks for packaging Banshee. The FE rpm, however, doesn't install
ipod-sharp automatically. It'd be nice if it did.

Version-Release number of selected component (if applicable):
banshee-0.10.7-1

How reproducible:
Install banshee with "yum install banshee" or pirut.
  
Actual results:
Banshee and other requirements are installed, but not ipod-sharp,
which in turn doesn't install libipoddevice. Ipod fails to work
with Banshee.

Expected results:
"yum install banshee" includes ipod-sharp and libipoddevice in
the requirements, making Banshee ipod-enabled

Additional info:
Comment 1 Christopher Aillon 2006-03-09 09:27:37 EST
What platform is this on?  rpmbuild is supposed to auto generate that
dependency, and it should not be an explicit Requires:
Comment 2 Aaron Kurtz 2006-03-09 12:17:32 EST
Just standard x86, on a new installation of FC5t3.
Comment 3 Christopher Aillon 2006-03-09 12:58:09 EST
% rpm -q --requires banshee | grep ipod
mono(ipod-sharp) = 0.0.1.0
% rpm -q --whatprovides "mono(ipod-sharp)"
ipod-sharp-0.5.15-2
banshee-0.10.7-1


So the problem seems to be that banshee doesn't use the installed copy of
ipod-sharp.  I remember talking to Aaron Bockover about this last week, and the
packaging ramifications slipped my mind at the time.

This is intentional because ipod-sharp isn't yet stable.  So, it copies over the
dlls and uses those.  Thus, it needs ipod-sharp but since we built it into the
banshee package, it satisfies its own dependency on ipod-sharp, and ipod-sharp
and libipoddevice don't get installed...
Comment 4 Christopher Aillon 2006-03-09 13:18:21 EST
Building a new package with an explicit Requires: libipoddevice.

Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.