Bug 18449 - gnome-name-service Problem
gnome-name-service Problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-05 13:14 EDT by Bill Chatfield
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-13 19:30:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Chatfield 2000-10-05 13:14:00 EDT
The gnome-name-server keeps logging me out when I'm away from my desktop
overnight.  This is the only information I have.  I just come back and I
have a login screen instead of my desktop.

From /var/log/messages:

Oct  5 03:14:28 jhad gnome-name-server[1014]: input condition is: 0x10,
exiting
Oct  5 03:14:30 jhad PAM_unix[886]: (system-auth) session closed for user
bchat
Oct  5 03:14:31 jhad PAM_unix[886]: (system-auth) session closed for user
bchat
Oct  5 03:14:32 jhad gdm[886]: gdm_auth_user_remove: /home/bchat is not
owned by uid 0.
Oct  5 03:14:32 jhad gdm[886]: gdm_auth_user_remove: Ignoring suspiciously
looking cookie file /home/bchat/.Xauthority
Comment 1 Owen Taylor 2000-10-06 12:05:14 EDT
Thanks for the report. I believe the messsage about gnome-name-server
is a symptom rather than a problem. That is, the gnome-session program
that runs your gnome desktop crashes, and then gnome-name-server spits
some diagnostics as it (and everything else) dies.

We've had one other report of the problem, so your not alone - but it
seems to be pretty rare. Can you think of anything unusual about this
system? Is it an upgrade or a fresh install? What kind of apps do
you usually run on it?
Comment 2 Steven Ellis 2000-10-25 18:05:45 EDT
I'm having exactly the same problem.  I also think that the gnome-name-server log message is a symptom not a cause.  I've done some further 
research 
and found that my session gets killed nearly exactly 20 minutes after my screensaver kicks in.  I've tried changing the delay for the screensaver to 
start, 
and the session death occurs 20 minutes after the screensaver would have started.  I have DPMS turned off, but I'm wondering if somehow its trying to 
do 
that anyway, as the time set for DPMS after screensaver is 20 minutes (in ~/.gnome/Screensaver, I have:

[Default]
nice=4
waitmins=40
dpmsmins=20
dpms=false
password=false
mode=RANDOM SCREENSAVER
command=xscreensaver -no-splash -timeout 40 -nice 16

I'll try turning DPMS back on and also changing the dpmsmins value.  Sorry I don't remember the GUI way to get to these, I'm away from my machine 
at 
the moment.

-se
Comment 3 Bill Chatfield 2000-10-25 20:41:15 EDT
I run Netscape (standard RHL7 version), gnome-terminal, RealPlayer 7 connected
to netradio.com, ee, and sometimes Borland's JBuilder 3.5 with Blackdown's JDK
1.2.2 FCS.  I use the notif2 Gnome theme.

I have a Voodoo3 video card running at 1024x768 with a depth of 24.

I also have thought it might have something to do with DPMS, but I haven't been
able to determine anything for sure.
Comment 4 Steven Ellis 2000-11-03 00:54:16 EST
The settings I use for DPMS or not don't seem to make any difference.  I
continue to get my session killed 20 minutes after the screensaver cuts in.  I
found a workaround, however, if I disable the screensaver entirely, then my
session doesn't get killed.  My guess is that there is some gotcha in the
screensaver or related code.  I'm running the stock Xfree, using the nv driver
on a Canopus 2500 (Nvidia TNT) AGP video card at 1600x1200x 24 bit.  If it
matters, my PC is a 400Mhz PII on a BX chipset motherboard.

Until this gets resolved, I'll just turn off my monitor when I'm away from my
machine, and run without the screensaver.
Comment 5 Bill Chatfield 2000-11-05 01:09:12 EST
I'm not going to mark this as NOTABUG because someone else is having the same
problem.  However, I believe it was caused by a hardware problem on my machine. 
I've replaced my processor and motherboard.  It doesn't happen anymore.

If it means anything to the other people having this problem, this is the
hardware I replaced:

AMD K6-2 366 CPU              (could have been the problem?)
DFI P5BV3+/e motherboard      (most likely suspect)
3com 3c509 ISA network card   (second most likely suspect, I got it used)
Buslogic BT-958 SCSI card     (I'm confident this card worked)
Voodoo3 3000 video card       (It's basically brand new)
unknown floppy drive          (probably not the problem)

I guess there are two possibilities.  One of these parts was not functioning
correctly or Linux just doesn't work right with one of them.

If you're having this problem, look at the list and see if you have any of the
same hardware.  If you do it might be a problem with Linux.  If not, it's more
likely that I just had bad hardware.
Comment 6 Steven Ellis 2000-11-06 13:05:10 EST
Unfortunately, none of the hardware that Bill mentions he replaced when the problem went away is in my machine (except that I too have an unknown 
floppy drive).  My system is a PII-400, ASUS P2BX mb, Canopus Spectra 2500 (Nvidia TNT-based) video card, Diamond fireport20 SCSI, Maxtor 80gig 
IDE drive, Plextor ultraplex CD, HP DDS2 DAT, nokia 445Xi monitor, logitech cordless mouse, MS natural keyboard.  I do have a linksys KVM switch 
connected, it seems more likely that it could be that than the unknown floppy, but I doubt that it is either.
Comment 7 Scott Russell 2001-04-04 11:37:29 EDT
I've seen this as well and 95% of the time it's a problem with xscreensaver and
one of the screen hacks causing problems. Using xscreensaver .30 or .31 on Red
Hat 7.0 seems to work fine. Previously (I think it was version .28 or .29) I was
being kicked out to the GDM login after some time. Usually this meant locking
the screen for the night and finding a GDM login in the morning.
Comment 8 kithanas 2001-05-03 15:47:55 EDT
I'm encountering this same error as well. However, the gnome-name-server has even logged me out while I wasn't immediately doing anything but before 
the xscreensaver kicked in. It doesn't do it consistently either, but it does it frequently enough that it's very inconvienent. There isn't anything in the logs 
to indicate what is going on with this outside of what bill.chatfield@netcommunity.com has already listed at the beginning of this bug report. I am 
currently running kernel 2.2.19-7.0.1smp, on a pair of Celeron 500 on the Abit BP6 motherboard, the normal apps I have running within ximian GNOME 
1.2 (XFree86 4.0.3) are gnome-terminal, licq 1.0.3, xmms-helix 1.2.4, Netscape Communicator 4.77.
Comment 9 Need Real Name 2001-09-13 19:30:53 EDT
Bug 46911 appears to be the same bug as this.

We have been seeing this on *all* of our linux boxes, of various 
configurations.  The only similarities between them all is they 
are all dual processor Pentium machines (different CPU speeds and 
different motherboards, though), and they all have NVidia based 
video cards (but different NVidia cards).
Comment 10 Owen Taylor 2002-04-11 12:07:19 EDT
I think this bug just concerns a bunch of unrelated X server crashes
and doesn't reflect GNOME problems.

Since no additions have been made to this bug since 7.2 was released,
and since XFree86-4.1 which was shipped with 7.2 is significantly
different from the 4.0.3 version shipped with 7.1 (and XFree86-4.2
in the current beta is even more different) I'm going to close
the bug since I don't think there is useful information here at this
point.

Thanks for all the comments on the bug.

Note You need to log in before you can comment on or make changes to this bug.