Bug 184490 - Wireless broken after resume
Summary: Wireless broken after resume
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-09 09:26 UTC by Adam Huffman
Modified: 2008-03-11 11:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 11:11:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (28.62 KB, text/plain)
2006-03-09 09:38 UTC, Adam Huffman
no flags Details
lsmod output (2.67 KB, text/plain)
2006-03-09 09:40 UTC, Adam Huffman
no flags Details
lspci output (1.63 KB, text/plain)
2006-03-09 09:41 UTC, Adam Huffman
no flags Details

Description Adam Huffman 2006-03-09 09:26:22 UTC
Description of problem:
When I resume after having suspended using the latest kernel (1.2032), the
wireless network connection doesn't work.  There is a message from
gnome-power-manager "problem with suspend".

This worked with the 1.2009 kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.2032_FC5

How reproducible:
Every time

Steps to Reproduce:
1. Suspend via the system menu
2. Resume
3.
  
Actual results:
Wireless network is not found

Expected results:
Wireless network should be reconnected.

Additional info:

Machine is a Sony Vaio S1XP with Intel 2200 wireless chipset.

Comment 1 Adam Huffman 2006-03-09 09:38:31 UTC
Created attachment 125861 [details]
/var/log/messages

Comment 2 Adam Huffman 2006-03-09 09:40:28 UTC
Created attachment 125862 [details]
lsmod output

Comment 3 Adam Huffman 2006-03-09 09:41:14 UTC
Created attachment 125863 [details]
lspci output

Comment 4 Adam Huffman 2006-03-16 22:26:46 UTC
This problem appears to have been related to NetworkManager, in fact, and has
been mostly fixed by the 0.6.0-3 version of that package.

Comment 5 Adam Huffman 2006-04-13 07:15:27 UTC
Since the release of FC5, this has stopped working.  The only way I can get
NetworkManager to re-connect to my wireless network upon resuming the laptop is
to remove the ipw2200 module and then modprobe it again.  This didn't used to be
needed. 

The laptop is fully up to date.

Comment 6 Jeremy Katz 2006-09-21 17:24:23 UTC
Is this still happening with current kernels?

Comment 7 Adam Huffman 2006-09-21 23:31:10 UTC
As soon as suspend works again, I'll give it a try... (the machine is currently
running rawhide)

Comment 8 Adam Huffman 2006-10-15 12:30:50 UTC
It has now worked a couple of times with kernel 2.6.18-1.2784.fc6, albeit with
the fglrx driver (the stock radeon driver causes X to hang and vesa doesn't work
with suspend).

Comment 9 Adam Huffman 2006-11-19 21:38:03 UTC
Still having to use the fglrx driver, because radeon causes X to hang at the moment.

Comment 10 Richard Hughes 2007-05-24 14:49:03 UTC
Can you try some of the steps outlined here please:
http://people.freedesktop.org/~hughsient/quirk/

Thanks!

Comment 11 Adam Huffman 2008-03-11 11:11:09 UTC
Am closing this bug as the system has been upgraded and isn't in much use anymore.


Note You need to log in before you can comment on or make changes to this bug.