Bug 1844938 - OpenShift Web terminal should use updated custom resource for starting terminal workspaces
Summary: OpenShift Web terminal should use updated custom resource for starting termin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1846969
TreeView+ depends on / blocked
 
Reported: 2020-06-08 05:05 UTC by Angel Misevski
Modified: 2020-10-27 16:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The che-workspace-operator has removed support for the Workspace resource and replaced it with the DevWorkspace CRD. Consequence: The command line terminal will not be enabled with the latest che-workspace-operator. Fix: Move OpenShift command line terminal to use the DevWorkspace resource. Result: Once the che-workspace-operator is installed, the command line terminal will be enabled in OpenShift Console.
Clone Of:
Environment:
Last Closed: 2020-10-27 16:05:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5687 0 None closed Bug 1844938: Migrate to DevWorkspace CR for the terminal 2020-10-05 13:34:55 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:05:53 UTC

Description Angel Misevski 2020-06-08 05:05:26 UTC
Description of problem:
The workspace started to support the OpenShift web terminal needs to be updated to match the workspace operator.

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Always

Steps to Reproduce:
1. Start terminal as non-cluster-admin user using masthead terminal button 

Actual results:
Workspace is created as workspace.che.eclipse.org/v1alpha1/Workspaces

Expected results:
Workspace is created as devfile.io/v1alpha1/DevWorkspaces

Additional info:
Related workspace operator PR https://github.com/che-incubator/che-workspace-operator/pull/92

Comment 1 cvogt 2020-06-08 13:16:53 UTC
This change is needed as the current Workspace resource will no longer be supported causing the command line terminal to stop working.

Comment 4 Gajanan More 2020-07-07 05:30:51 UTC
I have verified the bugzilla on:
Build:4.6.0-0.nightly-2020-07-06-202123
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 6 errata-xmlrpc 2020-10-27 16:05:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.