Bug 1844944 - No default storage class in add disk
Summary: No default storage class in add disk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Yaacov Zamir
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-08 05:26 UTC by Guohua Ouyang
Modified: 2020-10-27 16:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:05:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
an example of sc dropdown in the console (91.31 KB, image/png)
2020-06-24 10:04 UTC, Yaacov Zamir
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6125 0 None closed Bug 1844944: No default storage class in add disk 2020-12-02 02:17:38 UTC
Github openshift console pull 6269 0 None closed Bug 1844944: Add default labels to default sc 2020-12-02 02:17:39 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:05:53 UTC

Description Guohua Ouyang 2020-06-08 05:26:12 UTC
Description of problem:
No default storage class in add disk, it should have a default storage class for users who don't know what to use.

There is a default storageClass via `oc get sc`.
$ oc get sc
NAME                          PROVISIONER                             RECLAIMPOLICY   VOLUMEBINDINGMODE      ALLOWVOLUMEEXPANSION   AGE
hostpath-provisioner          kubevirt.io/hostpath-provisioner        Delete          WaitForFirstConsumer   false                  5d
local-block                   kubernetes.io/no-provisioner            Delete          WaitForFirstConsumer   false                  5d
nfs                           kubernetes.io/no-provisioner            Delete          Immediate              false                  5d
ocs-storagecluster-ceph-rbd   openshift-storage.rbd.csi.ceph.com      Delete          Immediate              false                  5d
ocs-storagecluster-cephfs     openshift-storage.cephfs.csi.ceph.com   Delete          Immediate              false                  5d
openshift-storage.noobaa.io   openshift-storage.noobaa.io/obc         Delete          Immediate              false                  4d9h
standard (default)            kubernetes.io/cinder                    Delete          WaitForFirstConsumer   true                   5d3h

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-30-015116

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaacov Zamir 2020-06-24 10:04:47 UTC
Created attachment 1698556 [details]
an example of sc dropdown in the console

Comment 2 Tomas Jelinek 2020-07-10 06:57:28 UTC
We fixed some bugs last sprint, did not have capacity to fix this one. Setting upcoming sprint.

Comment 7 errata-xmlrpc 2020-10-27 16:05:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.