Bug 184512 - Fedora Core 5 Test 3 installer does not find IDE drives attached to promise Ultra100 TX2 IDE controller
Fedora Core 5 Test 3 installer does not find IDE drives attached to promise U...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 09:06 EST by Vince Worthington
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 11:11:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vince Worthington 2006-03-09 09:06:03 EST
Description of problem:

Summary covers it pretty well.  The boot/installer kernel finds the controller
as it enumerates the hardware, as anything recent always has, as a Promise
PDC20268 IDE controller, and also finds the two 40GB hard drives attached to it.
 Everything looks normal/fine, the drives are called hde and hdg as usual. 
However when Anaconda begins and storage is scanned to find somewhere to install
to, the drives are not found.  All it finds is "/dev/mapper/pdc_jeaegcfh", which
it does see to be the correct size for one of the hard drives.

This is *NOT* one of the Promise "fake raid" controllers, it is strictly a PCI
IDE controller (and I wouldn't want to use promise fake raid anyway).

I even did a 'dd if=/dev/zero of=/dev/hd(e|g) bs=1024 count=10' and also one
calculated to write zeros to the last 100 cylinder-sized byte counts of each
drive, though I don't think either of these drives have ever been used as any
part of a linux software raid or a promise fake raid setup.  No effect.

Version-Release number of selected component (if applicable):
Fedora Core 5 Test 3 4.92

How reproducible:
always

Steps to Reproduce:
1. Put a Promise Ultra 100 TX2 (PDC 20268 chipset) PCI IDE controller in
2. Attach hard drives
3. Try to install and have the drives seen by Anaconda
  
Actual results:
All it finds is "/dev/mapper/pdc_jeaegcfh"

Expected results:
Should find the two IDE drives hde and hdg like the kernel itself sees when booting.

Additional info:
Comment 1 Vince Worthington 2006-03-09 09:08:29 EST
Correction, meant to say I don't think either drive has ever been used as part
of a promise fake raid, they were used for 3 software RAID1's on the FC4 box
they were pulled out of.
Comment 2 Peter Jones 2006-03-09 11:11:58 EST
The drives have definitely been used as a promise fake raid controller.  The
best thing to do here is probably to remove the metadata from the disks, but we
can't really do that automatically because it is somewhat dangerous if you're
not reusing the entire disk, or not all the disks in the set.

You can remove them by doing:

dmraid -r /dev/hde /dev/hdg -E -f pdc

(the "dd" command you used doesn't work because the magic data is near the end
of the disk, not the beginning)

If for some reason removing the metadata isn't an option, you can boot the
installer with "nodmraid" on the command line, and it'll ignore any metadata it
finds.

Note You need to log in before you can comment on or make changes to this bug.