Bug 1845188 - service-ca.cert file not mounted on cluster pods [reverting bug 1813894]
Summary: service-ca.cert file not mounted on cluster pods [reverting bug 1813894]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: service-ca
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.0
Assignee: Maru Newby
QA Contact: scheng
URL:
Whiteboard:
: 1847174 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-08 15:35 UTC by Ohad
Modified: 2020-07-13 17:43 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:43:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:43:46 UTC

Internal Links: 1842233

Description Ohad 2020-06-08 15:35:34 UTC
Description of problem:

noobaa-operator (a component in the OpenShift Container Storage product) is relying on the existence of the service-ca.cert file on its containers in order to function properly.
As of OCP 4.5.0 this file is not mounted anymore at  var/run/secrets/kubernetes.io/serviceaccount/service-ca.crt or at any other place

A search on previous versions documentation (4.4 and 4.3) does not mention this feature as being deprecated.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Deploy an OCS cluster
2. use "oc -n openshift-storage rsh $(oc -n openshift-storage get pod -o name -l noobaa-operator)" to open a remote session to a noobaa-operator container.
3. use "ls -l var/run/secrets/kubernetes.io/serviceaccount" to verify that the file does not exist.

Actual results:
The file does not exist in the mentioned location

Expected results:
The file should be mounted at that location


Additional info:

Comment 6 Xingxing Xia 2020-06-10 01:16:05 UTC
Why reverting? If reverting, then one of this bug and another bug 1813894 will be NOTA.

Comment 7 Xingxing Xia 2020-06-10 01:18:07 UTC
Ah, got it in bug 1813894#c12 . Let me hold on the 4.5 release note https://github.com/openshift/openshift-docs/issues/19847#issuecomment-641007166

Comment 9 Maru Newby 2020-06-10 15:02:15 UTC
Given that this bz represents an unreleased regression, no doc text is required.

Comment 10 Maru Newby 2020-06-15 20:28:40 UTC
*** Bug 1847174 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2020-07-13 17:43:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.