Bug 184543 - system-config-soundcard finds card, but doesn't configure sound
system-config-soundcard finds card, but doesn't configure sound
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 14:06 EST by Boris Zbarsky
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:30:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file (11.05 KB, text/plain)
2006-03-09 14:07 EST, Boris Zbarsky
no flags Details
Updated log file (11.23 KB, text/plain)
2006-03-12 23:48 EST, Boris Zbarsky
no flags Details
Log file for 1.0.11 drivers (10.77 KB, text/plain)
2006-06-02 13:54 EDT, Boris Zbarsky
no flags Details

  None (edit)
Description Boris Zbarsky 2006-03-09 14:06:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060206 SeaMonkey/1.5a

Description of problem:


Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.12-5.FC4

How reproducible:
Always

Steps to Reproduce:
1) Install Fedora Core 4
2) Run "yum update"
3) Run system-config-soundcard as root.
4) Notice that it detects your sound card (or at least lists the right card)
5) Click the "Play test sound" button

Actual Results:  No sound.

Expected Results:  Sound plays.

Additional info:

On the same exact hardware, the previously installed Red Hat 8 system does have working sound (tested by rebooting back and forth twice last night).  So the hardware end of this (card, cabling, speakers, etc) seems to be ok.  The right kernel modules do seem to be loaded accoding to lsmod.  I've checked with alsamixer, and all the channels are unmuted and at a reasonable volume.

The sound card is a built-in (on the motherboard) thing in this case, if that matters.

I'll attach the scsound.log file that is generated.
Comment 1 Boris Zbarsky 2006-03-09 14:07:50 EST
Created attachment 125892 [details]
Log file
Comment 2 Martin Stransky 2006-03-10 10:40:14 EST
Have you checked any mixer switches (in alsamixer, it's command-line utility)?

btw. you have quite old driver so check the new one, how-to is here: 
http://people.redhat.com/stransky/alsa
Comment 3 Boris Zbarsky 2006-03-10 11:08:44 EST
> Have you checked any mixer switches (in alsamixer, it's command-line utility)?

How do I tell?

> btw. you have quite old driver so check the new one, how-to is here: 
> http://people.redhat.com/stransky/alsa

I'm tryng to follow those instructions...  I need to both install the tarball in
step 2 _and_ the RPM in step 6, right?

Comment 4 Martin Stransky 2006-03-10 11:22:36 EST
> How do I tell?

I mean some switches like "Phone", "PCM Out Path & Mute" and so on...

> step 2 _and_ the RPM in step 6, right?

Right, you need drivers and apropriate alsa-lib and alsa-util package....
Comment 5 Boris Zbarsky 2006-03-10 11:30:19 EST
"Phone" is unmuted and at 100%.  "PCM Out Path & Mute" is set to "pre 3D".  I
can change any of these to whatever values needed.  :)

I'll try the newer drivers this afternoon, hopefully.  Thanks!
Comment 6 Boris Zbarsky 2006-03-12 23:48:51 EST
Created attachment 126017 [details]
Updated log file

I realized on Friday that there were updates for both the kernel and the
alsa-utils and alsa-lib packages for FC4.  So I installed those; this is the
resulting log.	I compared the source for alsa-driver-1.0.10rc3 to that for
alsa-driver-1.0.10 (final) and I don't see any changes in the es1371 driver
between the two revisions, but if you want I guess I can still try the
alsa-driver-1.0.10 tarball from the alsa website...  I'd prefer to avoid that
if it's not necessary, though -- I kinda like sticking to packages as much as I
can.  ;)  If I do need to try it, would I want to use the .src.rpm from
http://people.redhat.com/stransky/alsa/ or the one from FC4 updates?
Comment 7 Boris Zbarsky 2006-03-13 00:06:09 EST
So I just noticed that the sound card is sharing IRQ 11 with one of the network
cards (according to lspci -v).  Does that matter?  I'm suspecting "no", but just
checking....
Comment 8 Martin Stransky 2006-03-13 10:00:27 EST
IRQ 11 should not be a problem. I recommend you to check 1.0.10 or 11.rc3
drivers and then (if sound still doesn't works) look for other solutions....
Comment 9 Boris Zbarsky 2006-03-13 17:31:09 EST
OK, I've tried the 1.0.11rc3 drivers and still no sound.
Comment 10 Martin Stransky 2006-03-30 05:17:33 EST
On my page are new alsa packages (1.0.11rc4) so you may check them...
Comment 11 Boris Zbarsky 2006-05-09 12:34:31 EDT
I'm still looking for a time when I can take this machine down so I can test
this stuff.  Things most emphatically do NOT work for me.
Comment 12 Martin Stransky 2006-05-17 10:54:29 EDT
Or you can report your problem to ALSA project
(https://bugtrack.alsa-project.org/alsa-bug/), don't forget to attach some
useful information (/root/scsound.log, output of "lspci -vn")
Comment 13 Boris Zbarsky 2006-05-17 13:52:42 EDT
Thanks for the pointer.  I reported
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2132
Comment 14 Boris Zbarsky 2006-06-02 13:54:28 EDT
Created attachment 130413 [details]
Log file for 1.0.11 drivers

I installed the 1.0.11 driver tarball from
http://people.redhat.com/stransky/alsa/ and tried it.  This is the resulting
scsound.log.  I still get no sound.
Comment 15 Martin Stransky 2006-06-05 04:56:45 EDT
Hm, I really don't know...
Comment 16 Martin Stransky 2006-08-04 16:30:11 EDT
closing as upstream...

Note You need to log in before you can comment on or make changes to this bug.