Bug 184552 - dbscan fail to run, linked to libdb41 which doesn't exist (only libdb42)
dbscan fail to run, linked to libdb41 which doesn't exist (only libdb42)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Directory Server
Classification: Red Hat
Component: Command Line Utilities (Show other bugs)
6.21
All Linux
medium Severity medium
: ---
: ---
Assigned To: Noriko Hosoi
Chandrasekar Kannan
:
Depends On:
Blocks: 146725 182630 184343
  Show dependency treegraph
 
Reported: 2006-03-09 15:03 EST by To Ngan
Modified: 2015-01-04 18:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 14:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cvs diff components.mk ldap/cm/Makefile ldap/servers/slapd/tools/Makefile; new file: dbscan.c (27.94 KB, text/plain)
2006-03-09 16:50 EST, Noriko Hosoi
no flags Details
cvs commit message (1.53 KB, text/plain)
2006-03-09 19:54 EST, Noriko Hosoi
no flags Details

  None (edit)
Description To Ngan 2006-03-09 15:03:05 EST
Description of problem:
dbscan fail to run, linked to libdb41 which doesn't exist (only libdb42)

Found when I am trying to back port indexes test suite from DS 7.1 branch to DS
6.21 branch


Version-Release number of selected component (if applicable):
DS 6.21 SP3.  This is not a regression in SP3.  Previously we built special
dbscan for HP.

How reproducible:
Consistently

Steps to Reproduce:
1. Install server
2. cd [server root]/bin/slapd/server
3. run ./dbscan
  
Actual results:
It complains can't find libdb41 library

Expected results:
Should run successfully and return usage message.


We may decide to later this bug since it is not a regression. (I'll make it
block SP3 for now)
Comment 1 Noriko Hosoi 2006-03-09 16:50:33 EST
Created attachment 125907 [details]
cvs diff components.mk ldap/cm/Makefile ldap/servers/slapd/tools/Makefile; new file: dbscan.c

Files:
components.mk
ldap/cm/Makefile
ldap/servers/slapd/tools/Makefile
ldap/servers/slapd/tools/dbscan.c

Changes:
build dbscan inside of DS6.21 build; don't pull it from DSRK

Ldd output on Linux (there's no more dependency on libdb41.so)
ldd Linux/dbscan
	libssldap50.so => not found
	libldap50.so => not found
	libprldap50.so => not found
	libdb42.so => not found
	libslapd.so => not found
	libssl3.so => not found
	libnss3.so => not found
	libsoftokn3.so => not found
	libplc4.so => /usr/lib/libplc4.so (0x40023000)
	libplds4.so => /usr/lib/libplds4.so (0x40028000)
	libnspr4.so => /usr/lib/libnspr4.so (0x4002b000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x40058000)
	libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3
(0x40085000)
	libm.so.6 => /lib/i686/libm.so.6 (0x400c8000)
	libc.so.6 => /lib/i686/libc.so.6 (0x400eb000)
	libpthread.so.0 => /lib/i686/libpthread.so.0 (0x40227000)
	libdl.so.2 => /lib/libdl.so.2 (0x4023c000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

The rebuilt dbscan are placed in /share/dev2/devel/nhosoi/dbscan/<platform>.
Comment 2 To Ngan 2006-03-09 16:57:15 EST
I dropped in the new dbscans from /share/dev2, they seem to work.
Comment 3 Noriko Hosoi 2006-03-09 19:54:52 EST
Created attachment 125912 [details]
cvs commit message

Reviewed by Rich (Thank you!)
Comment 4 Noriko Hosoi 2006-03-09 19:57:57 EST
*DOCS*
rebuilt dbscan linked to the same libdb version 4.2 used by the Directory Server.
Comment 5 To Ngan 2006-03-14 10:21:20 EST
Verified candidate 20060310.1 on all platforms.
Comment 6 David Lawrence 2006-04-18 10:50:54 EDT
PASSES_QA status has been deprecated in favor of VERIFIED. Changing status to
VERIFIED.
Comment 7 Chandrasekar Kannan 2007-07-25 15:16:16 EDT
DS7.2 is not a valid milestone anymore. Anything thats set to DS7.2 should be
set to DS8.0. Will make further changes per bug council on 07/24/2007, after this.

Note You need to log in before you can comment on or make changes to this bug.