Bug 1845588 - opm does not respect whiteout files when unpacking images with docker and podman
Summary: opm does not respect whiteout files when unpacking images with docker and podman
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Nick Hale
QA Contact: Tom Buskey
URL:
Whiteboard:
: 1860124 (view as bug list)
Depends On: 1841178
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-09 14:59 UTC by OpenShift BugZilla Robot
Modified: 2020-09-30 14:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: opm treats whiteout files the same as normal files during unpacking for podman and docker tooling options. Consequence: Whiteout files show up in unpacked content when using podman or docker tooling options. Fix: Use docker/podman run and copy to properly apply whiteout files during unpacking. Result: Whiteout files are no longer present after unpacking with podman and docker tooling options.
Clone Of:
Environment:
Last Closed: 2020-09-30 14:06:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-registry pull 400 0 None closed [release-4.5] Bug 1845588: fix(images): use docker/podman create and cp for exec unpacking 2020-10-11 19:37:03 UTC
Red Hat Product Errata RHBA-2020:3760 0 None None None 2020-09-30 14:06:40 UTC

Comment 4 Nick Hale 2020-07-23 18:49:11 UTC
*** Bug 1860124 has been marked as a duplicate of this bug. ***

Comment 8 Evan Cordell 2020-09-11 13:21:15 UTC
This is cherry-pick approved and should merge today. If it doesn't, it will early next sprint.

Comment 14 Tom Buskey 2020-09-22 19:31:35 UTC
 opm alpha bundle validate --tag registry-proxy.engineering.redhat.com/rh-osbs/amq7-amq-streams-rhel7-operator-metadata:1.0.0-1
INFO[0000] Create a temp directory at /tmp/bundle-221563497  container-tool=docker
DEBU[0000] Pulling and unpacking container image         container-tool=docker
INFO[0000] running /bin/docker pull registry-proxy.engineering.redhat.com/rh-osbs/amq7-amq-streams-rhel7-operator-metadata:1.0.0-1  container-tool=docker
INFO[0001] running docker create                         container-tool=docker
DEBU[0001] [docker create registry-proxy.engineering.redhat.com/rh-osbs/amq7-amq-streams-rhel7-operator-metadata:1.0.0-1 ]  container-tool=docker
INFO[0001] running docker cp                             container-tool=docker
DEBU[0001] [docker cp ad055089fc9b75dc123dadc4235da70a463c54b0bff04c1f141cc4937eddf541:/. /tmp/bundle-221563497]  container-tool=docker
INFO[0001] running docker rm                             container-tool=docker
DEBU[0001] [docker rm ad055089fc9b75dc123dadc4235da70a463c54b0bff04c1f141cc4937eddf541]  container-tool=docker
INFO[0001] Unpacked image layers, validating bundle image format & contents  container-tool=docker
DEBU[0001] Found manifests directory                     container-tool=docker
DEBU[0001] Found metadata directory                      container-tool=docker
DEBU[0001] Getting mediaType info from manifests directory  container-tool=docker
INFO[0002] Found annotations file                        container-tool=docker
INFO[0002] Could not find optional dependencies file     container-tool=docker
DEBU[0002] Validating bundle contents                    container-tool=docker
DEBU[0002] Validating "apiextensions.k8s.io/v1beta1, Kind=CustomResourceDefinition" from file "amq-streams-kafka.crd.yaml"  container-tool=docker
DEBU[0002] Validating "apiextensions.k8s.io/v1beta1, Kind=CustomResourceDefinition" from file "amq-streams-kafkaconnect.crd.yaml"  container-tool=docker
DEBU[0002] Validating "apiextensions.k8s.io/v1beta1, Kind=CustomResourceDefinition" from file "amq-streams-kafkaconnects2i.crd.yaml"  container-tool=docker
DEBU[0002] Validating "apiextensions.k8s.io/v1beta1, Kind=CustomResourceDefinition" from file "amq-streams-kafkamirrormaker.crd.yaml"  container-tool=docker
DEBU[0002] Validating "apiextensions.k8s.io/v1beta1, Kind=CustomResourceDefinition" from file "amq-streams-kafkatopic.crd.yaml"  container-tool=docker
DEBU[0002] Validating "apiextensions.k8s.io/v1beta1, Kind=CustomResourceDefinition" from file "amq-streams-kafkauser.crd.yaml"  container-tool=docker
DEBU[0002] Validating "operators.coreos.com/v1alpha1, Kind=ClusterServiceVersion" from file "amq-streams.v1.0.0.clusterserviceversion.yaml"  container-tool=docker
INFO[0002] All validation tests have been completed successfully  container-tool=docker

Comment 16 errata-xmlrpc 2020-09-30 14:06:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.13 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3760


Note You need to log in before you can comment on or make changes to this bug.