Bug 184560 - Add the ability to associate keystrokes for brightness in/decreasing to gnome-keybinding-properties, for laptops
Summary: Add the ability to associate keystrokes for brightness in/decreasing to gnome...
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: Desktop
Depends On:
Blocks: 183425
TreeView+ depends on / blocked
 
Reported: 2006-03-09 21:03 UTC by Suzanne Hillman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 16:53:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Suzanne Hillman 2006-03-09 21:03:02 UTC
Description of problem:
Add the ability to associate keyboard shortcuts for brightness in/decreasing to
gnome-keybinding-properties, for laptops. 

Right now, probably because the keystrokes vary between laptops, unless the
keystroke which is intended to do this talks directly to the hardware, there is
no way that I can see to increase or decrease brightness of laptop displays. If
there were two added effects added to gnome-keybinding-properties which could be
associated with keystrokes, this would no longer be a problem.

I note, of course, that I have no idea if the necessary things to talk to the
hardware to _do_ this exist or are consistent between laptops.

Version-Release number of selected component (if applicable):
control-center-2.13.92-2

How reproducible:
Always

Steps to Reproduce:
1. Find a machine whose brightness level modifiers are a keystroke, which does
not talk to the hardware directly (like the Fujitsu Lifebook)
  
Actual results:
Trying to modify the brightness has no effect, and there is no way to tell the
machine that that is what you expect the key stroke to do.

Expected results:
Should be able to just work, or be able to appropriate associate the keystroke.

Additional info:

Comment 1 Suzanne Hillman 2006-03-21 21:47:25 UTC
Alright. I had no idea that Fn keys generally talk to BIOS or APCI stuff, so
there is unlikely to be anything to do in gnome-keybinding-properties to fix
this. I'll work on a new bug report against the kernel, as that's probably where
the problem is.

Comment 2 Suzanne Hillman 2006-03-22 16:53:47 UTC
Created new bug 186268; closing this one.


Note You need to log in before you can comment on or make changes to this bug.