Bug 1845602 - [CNV 2.4][UI] openshift-cnv namespace is not created during installation and not used when exists
Summary: [CNV 2.4][UI] openshift-cnv namespace is not created during installation and ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1845639 (view as bug list)
Depends On: 1845031
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-09 15:54 UTC by Jakub Hadvig
Modified: 2020-07-30 18:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-30 18:56:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
verification screenshot for scenario B (4.33 MB, video/quicktime)
2020-07-23 06:44 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5703 None closed [release-4.5] Bug 1845602: Dont update TargetNamespace when switching UpdateChannels 2020-07-29 12:27:57 UTC
Red Hat Product Errata RHBA-2020:3028 None None None 2020-07-30 18:57:18 UTC

Description Jakub Hadvig 2020-06-09 15:54:19 UTC
This bug was initially created as a copy of Bug #1845031

I am copying this bug because: 



Description of problem:
When user procieeds installation steps for CNV Operator from 2.4 channel, the namespace openshift-cnv is not created automatically.
When namespace openshift-cnv is created before the installation, it isn't used when user navigates to the OperatorHub from a different namespace (for example, openshift-cnv ns is created with CLI, user is currently in Default namespace in the UI and navigates to Operator Hub to install CNV Operator). Instead, the last active namespace is used (In the previous example, it would be Default).

Version-Release number of selected component (if applicable):
4.5.0-rc.1
CNV-2.4

How reproducible:
100%

Steps to Reproduce:
a)
1. Make sure openshift-cnv namespace doesn't exist
2. Navigate to OperatorHub, search container-native, click install, select 2.4 channel, click install

b) 
1) Create openshift-cnv namespace
2) Switch to 'Default' project
3) Navigate to OperatorHub, search container-native, click install, select 2.4 channel, click install


Actual results:
the Openshift Virtualization operator is deployed to the last active namespace, not openshift-cnv

Expected results:

a) openshift-cnv namespace should be created for the user

b) when openshift-cnv namespace exists, it should be used instead of the least recently used namespace
   it shouldn't matter from which namespace the user navigates to the operatorHub


Additional info:

Comment 1 Jakub Hadvig 2020-06-19 07:17:28 UTC
Waiting to dependent bug gets Verified. Adding UpcomingSprint to have it reevaluated in the next cycle.

Comment 3 Jakub Hadvig 2020-07-15 13:13:01 UTC
*** Bug 1845639 has been marked as a duplicate of this bug. ***

Comment 6 XiaochuanWang 2020-07-23 06:44:41 UTC
Created attachment 1702163 [details]
verification screenshot for scenario B

Comment 7 XiaochuanWang 2020-07-23 06:47:13 UTC
Scenario a) Namespace created successfully together with the operator
Scenario b) Browsed to Default namespace and created the operator successfully automatically under openshift-cnv (attached the screen recording for refer)

This could be verified on 4.5.0-0.nightly-2020-07-23-023500

Comment 9 errata-xmlrpc 2020-07-30 18:56:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3028


Note You need to log in before you can comment on or make changes to this bug.