Bug 184565 - reinstall made the mac unbootable
reinstall made the mac unbootable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 16:24 EST by Arnd Bergmann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-17 18:22:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnd Bergmann 2006-03-09 16:24:01 EST
Description of problem:  
  
After installing fc5-devel, yaboot got installed in a way that it did 
not boot any more. 
  
Version-Release number of selected component (if applicable):  
  
 netinstall image from 2006-03-09 8:30 CET 
 
How reproducible:  
 
The partition table setup was a little weird. I used to have 
 
/dev/sda1 Apple 
/dev/sda2 bootstrap 
/dev/sda3 unused 
/dev/sda4 MacOS 
/dev/sda5 Gentoo 
/dev/sda6 fc4 
/dev/sda7 home 
 
As a good fedora user, I decided to get rid of the Gentoo partition and 
replaced it with a fresh install: 
 
/dev/sda5 fc5 
/dev/sda8 swap 
/dev/sda9 unused 
 
Anaconda crashed on me during install when I switched between console 
and the installer. I restarted the install process without changing 
the partitions again. This time the installation worked fine, until 
the final reboot. 
 
The first stage boot loader tried to load the second stage and ended up 
with a blank grey screen instead. poking around in the file system 
and in OF showed that 
 
- boot-device had been set to 'disk@0:8,\\:tbxi' (the swap device) 
- yaboot.conf contained 'boot=/dev/sda2 /dev/sda8' (I suppose it should 
  only ever have one device in there, and not the swap). 
 
Parted print showed: 
 
Disk geometry for /dev/sda: 0kB - 160GB 
Disk label type: mac 
Number  Start   End     Size    File system  Name                  Flags 
1       1kB     32kB    32kB                 Apple 
2       33kB    851kB   819kB   hfs          bootstrap             boot 
3       852kB   2148MB  2147MB               untitled 
4       2148MB  56GB    54GB    hfs+         untitled 
5       56GB    66GB    10GB    ext3         untitled 
8       66GB    68GB    2097MB  hfs          swap                  swap 
9       68GB    110GB   41GB    ext3         untitled 
6       110GB   115GB   5369MB  ext3         fedora 
7       115GB   160GB   45GB    ext3         home 
 
Note that partition eight is used as swap but maked as using hfs. 
 
I tried lots of stuff to fix the situation, including: 
- fix yaboot.conf to not point to /dev/sda8 
- run ybin and mkofboot a few times 
- erasing the nvram and OF settings 
 
At some point I noticed that there was no devalias 'disk' anymore, so 
I tried looking at 'hd'. Changing boot-device to 'hd:,\yaboot' made it 
possible to boot again.
Comment 1 Paul Nasrat 2006-03-09 16:52:04 EST
Thanks for the report, I'll try and reproduce by setting up a box here similarly.
Comment 2 Paul Nasrat 2006-07-17 18:22:21 EDT
I've commited a fix to this to booty.

Note You need to log in before you can comment on or make changes to this bug.