Bug 184567 - Buttons on Fujitsu Lifebook P Series (P1510D) not caught by X
Buttons on Fujitsu Lifebook P Series (P1510D) not caught by X
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Desktop, FutureFeature
Depends On:
Blocks: 183425
  Show dependency treegraph
 
Reported: 2006-03-09 16:37 EST by Suzanne Hillman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 12:00:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2006-03-09 16:37:34 EST
Description of problem:
There are buttons specific to the Fujitsu Lifebook P Series (P1510D) which seem
to not be caught by X.

They are located below the screen, on the left-hand side. They appear to be
intended to work on their own, but have a second function when the function key
is pressed at the same time.

The first is a down-arrow and "A", and is apparently intended to be for page
down, and something user-defined (there is a default of the calculator, but I'm
not sure it matters).

The second is an up-arrow, and "B", is intended for page up and something
user-defined (the default is something called MS Journal, which I suspect is
intended to work together with the tablet function, as this is a tablet laptop)

The third is a graphic showing screen rotation, and looks to be intended to
allow one to change between landscape and portrait orientations. (I will be
entering another bug to deal with the fact that it's apparently supposed to
automatically change to portrait mode when one moves the screen into tablet
mode) The function key is apparently supposed to tell it to talk to VGA-out. I'm
not completely sure what this means, and the manual I downloaded seems to be
missing words around that. (I'd figure it's something similar to the ability to
tell the machine to use an external video instead of or in addition to the
laptop screen, which exists on another function key as well)

The fourth is another Fn button in addition to the one on the keyboard
(presumably for use when one is in tablet mode, since one cannot get to the
keyboard then), and when pressed twice in succession is supposed to bring up the
(presumably Windows-based) fujitsu menu utility. Probably not something we can
do anything about.

Finally, the fifth is supposed to be a ctl+alt+del button, with no expected
Function-altered use.

At the least, these buttons should be available to associate with actions.
Better yet would of course setting them up as close as possible to their
original intention (especially for their non-Function-altered uses).

I've set this to enhancement, although I'm not completely sure that's accurate.
Comment 1 Mike A. Harris 2006-03-10 19:54:16 EST
Please file a bug report in the X.Org bugzilla located at
http://bugs.freedesktop.org in the "xkeyboard-config" component for this
issue.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", and awaiting upstream
bug report URL for tracking.

Thanks in advance.
Comment 2 Suzanne Hillman 2006-03-13 11:27:44 EST
https://bugs.freedesktop.org/show_bug.cgi?id=6251

Note You need to log in before you can comment on or make changes to this bug.