Bug 184593 - System clock runs way too fast with kernel-2.6.15-1.2032_FC5
System clock runs way too fast with kernel-2.6.15-1.2032_FC5
Status: CLOSED DUPLICATE of bug 55223
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 21:41 EST by John Thacker
Modified: 2015-01-04 17:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 00:13:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg with kernel-2.6.15-1.2038_FC5 (clock too fast) (16.29 KB, text/plain)
2006-03-10 19:42 EST, John Thacker
no flags Details
dmidecode with kernel-2.6.15-1.2038_FC5 (12.18 KB, text/plain)
2006-03-10 19:43 EST, John Thacker
no flags Details
dmesg with kernel-2.6.15-1.2009.4.2_FC5 (works) (15.63 KB, text/plain)
2006-03-10 19:45 EST, John Thacker
no flags Details

  None (edit)
Description John Thacker 2006-03-09 21:41:00 EST
Description of problem:
After updating to kernel-2.6.15-1.2032_FC5, I noticed that my system clock
started running WAY too fast.  I gained an entire hour in about a day.  (The
clock runs so fast it can't stay in sync with NTP servers.)  My hardware clock
is perfectly fine.  Rebooting to kernel-2.6.15-1.2009.4.2_FC5 makes it work
perfectly.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.2032_FC5

How reproducible:
Every time

Steps to Reproduce:
1. Boot in that kernel
  
Actual results:
System clock runs way too fast

Expected results:
System clock runs normally

Additional info:
It works perfectly fine on the previous kernel, kernel-2.6.15-1.2009.4.2_FC5,
both before and after rebooting to it.
Comment 1 John Thacker 2006-03-10 12:27:36 EST
Problem persists on todays kernel-2.6.15-1.2038_FC5.  Rebooting to
kernel-2.6.15-1.2009.4.2_FC5 again works fine.  Any particular information that
would be helpful?
Comment 2 Dave Jones 2006-03-10 16:37:27 EST
dmesg and dmidecode output please ?
Comment 3 John Thacker 2006-03-10 19:42:48 EST
Created attachment 125969 [details]
dmesg with kernel-2.6.15-1.2038_FC5 (clock too fast)
Comment 4 John Thacker 2006-03-10 19:43:15 EST
Created attachment 125970 [details]
dmidecode with kernel-2.6.15-1.2038_FC5
Comment 5 John Thacker 2006-03-10 19:45:11 EST
Created attachment 125971 [details]
dmesg with kernel-2.6.15-1.2009.4.2_FC5 (works)

I didn't enter the nolapic keyword but it seems like it was disabled by
default.
Comment 6 John Thacker 2006-03-10 20:18:20 EST
Booting with 'noapic' makes it work fine.  I can add another dmesg if it would help.
Comment 7 Joachim Frieben 2006-03-13 03:40:37 EST
Looks like a duplicate of Bug #55223 albeit striking uni-processor
kernels, too, now. I had reopened Bug #55223 on 2006-03-05 after
observing the same regression which had occurred some time in
January 2006.
Comment 8 John Thacker 2006-03-30 00:13:06 EST
Seems to be working fine with kernel-2.6.16-1.2080_FC5 even without noapic.  Thanks!
Comment 9 John Thacker 2006-04-20 19:48:54 EDT

*** This bug has been marked as a duplicate of 55223 ***

Note You need to log in before you can comment on or make changes to this bug.