Bug 184599 - anaconda creates incomplete grub device.map
anaconda creates incomplete grub device.map
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 23:27 EST by Alex Stewart
Modified: 2008-03-10 21:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 21:19:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
device.map created by anaconda (82 bytes, text/plain)
2006-03-09 23:35 EST, Alex Stewart
no flags Details
device.map created by grub (45 bytes, text/plain)
2006-03-09 23:36 EST, Alex Stewart
no flags Details

  None (edit)
Description Alex Stewart 2006-03-09 23:27:29 EST
Description of problem:

I have tried a couple of times to install FC5test3 on my second hard drive
(/dev/hdb).  In both cases, the installer runs perfectly normally and installs
everything properly, but when I then reboot the system, I'm presented with a
broken grub installation.

I believe this is because anaconda appears to be creating a
/boot/grub/device.map file which is missing /dev/hdb. Grub therefore fails to
install properly because it cannot find a BIOS map for the drive on which the
new FC5 system has been installed.

If I boot in rescue mode and run 'grub-install /dev/hda', it complains about the
missing info for hdb.  If I run 'grub-install --recheck /dev/hda' it
re-generates the device.map file correctly (including hdb) and is able to
install just fine.

Version-Release number of selected component (if applicable):


How reproducible:

  Always

Steps to Reproduce:
1. Install FC5 on /dev/hdb
2. Reboot
3.
  
Actual results:

  Grub is not installed

Expected results:

  Bootable system

Additional info:
Comment 1 Alex Stewart 2006-03-09 23:35:08 EST
Created attachment 125924 [details]
device.map created by anaconda
Comment 2 Alex Stewart 2006-03-09 23:36:13 EST
Created attachment 125925 [details]
device.map created by grub
Comment 3 George C. Wilson 2006-12-13 18:44:33 EST
This is a regression. I understand that only Red Hat can change Issue Tracker
descriptions. Red Hat, please annotate this bug and its associated Issue Tracker
with [REG].
Comment 4 Konrad Rzeszutek 2006-12-14 15:46:32 EST
George.

Which Issue Tracker #?
Comment 5 Konrad Rzeszutek 2007-01-24 10:31:01 EST
I think this is fixed in RHEL5, but I am not sure if the fix made it in rawhide?
Comment 6 Matthew Miller 2007-04-06 14:04:27 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 7 petrosyan 2008-03-10 21:19:32 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.