Bug 184605 - Fails with Fascist Build Policy; Built Files not in SPEC
Summary: Fails with Fascist Build Policy; Built Files not in SPEC
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: MAKEDEV (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-10 05:16 UTC by Joseph D. Wagner
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 3.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-10 12:48:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of attempted build. (4.23 KB, text/plain)
2006-03-10 05:17 UTC, Joseph D. Wagner
no flags Details

Description Joseph D. Wagner 2006-03-10 05:16:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux 2.6.15-1.1833_FC4; X11; i686; en_US) KHTML/3.5.1 (like Gecko)

Description of problem:
To catch potential problems with SPEC files, rpmbuild checks if any files are 
in the %RPM_BUILD_ROOT directory that aren't listed in the %files section of 
the SPEC files (a.k.a. The Fascist Build Policy).  rpmbuild for this package 
fails at this check. 

Version-Release number of selected component (if applicable):
MAKEDEV-3.19-1.src.rpm

How reproducible:
Always

Steps to Reproduce:
Simply execute the following command on systems with rpm-build >= 4.4: 
rpmbuild --rebuild MAKEDEV-3.19-1.src.rpm 

Actual Results:  rpmbuild exited with error when it found files built that were not part of the 
package. 

Expected Results:  The package should have been built successfully. 

Additional info:

The Fascist Build Policy cannot be turned off from the command line.

Comment 1 Joseph D. Wagner 2006-03-10 05:17:40 UTC
Created attachment 125930 [details]
Log of attempted build.

Comment 2 Nalin Dahyabhai 2006-03-10 12:48:22 UTC
Looks like Florian fixed this in time for 3.20-1.  Marking as fixed in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.