Bug 1846112 - Upgrade from OCP 4.3.z to 4.4.0 with v1alpha1 snapshot CRDs fails.
Summary: Upgrade from OCP 4.3.z to 4.4.0 with v1alpha1 snapshot CRDs fails.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.z
Assignee: Christian Huffman
QA Contact: Chao Yang
URL:
Whiteboard:
: 1843959 (view as bug list)
Depends On: 1835869
Blocks: 1858168
TreeView+ depends on / blocked
 
Reported: 2020-06-10 19:30 UTC by OpenShift BugZilla Robot
Modified: 2020-07-23 18:02 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-22 12:20:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-storage-operator pull 60 None closed Bug 1846112: Includes validation check for VolumeSnapshot v1alpha1 CRDs 2020-08-27 18:56:25 UTC
Red Hat Product Errata RHBA-2020:2956 None None None 2020-07-22 12:21:08 UTC

Comment 3 Christian Huffman 2020-06-18 16:44:25 UTC
*** Bug 1843959 has been marked as a duplicate of this bug. ***

Comment 5 Christian Huffman 2020-07-10 18:22:25 UTC
I've submitted [1] that includes both commits needed to resolve this issue.

[1] https://github.com/openshift/cluster-storage-operator/pull/60

Comment 10 errata-xmlrpc 2020-07-22 12:20:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2956


Note You need to log in before you can comment on or make changes to this bug.