Bug 1846134 - [rhel-6.10] skylake (06-4e-03) microcode update hangs
Summary: [rhel-6.10] skylake (06-4e-03) microcode update hangs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: microcode_ctl
Version: 6.10
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Eugene Syromiatnikov
QA Contact: Jeff Bastian
URL:
Whiteboard:
Depends On:
Blocks: 1848989 1848990
TreeView+ depends on / blocked
 
Reported: 2020-06-10 21:04 UTC by Eugene Syromiatnikov
Modified: 2020-06-24 17:47 UTC (History)
3 users (show)

Fixed In Version: microcode_ctl-1.17-33.29.el6_10
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1846119
: 1848989 1848990 (view as bug list)
Environment:
Last Closed: 2020-06-24 17:47:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:2742 None None None 2020-06-24 17:47:37 UTC

Description Eugene Syromiatnikov 2020-06-10 21:04:05 UTC
+++ This bug was initially created as a clone of Bug #1846119 +++

Description of problem:
Microcode revision 0xdc for CPU 06-4e-03 (Skylake) can cause the system to freeze when applying the early microcode update.  Late updates seem to be ok, at least on this system.

[root@intel-skylake-y-01 ~]# lscpu | egrep -i -e family -e model -e stepping
CPU family:          6
Model:               78
Model name:          Intel(R) Core(TM) m5-6Y54 CPU @ 1.10GHz
Stepping:            3

[root@intel-skylake-y-01 ~]# cat /sys/devices/system/cpu/cpu0/microcode/version 
0x2d

[root@intel-skylake-y-01 ~]# yum -y update microcode_ctl
...

[root@intel-skylake-y-01 ~]# rpm -q microcode_ctl
microcode_ctl-20191115-4.20200602.2.el8_2.x86_64

[root@intel-skylake-y-01 ~]# rpm -q --provides microcode_ctl | grep iucode_rev.*06-4e-03
iucode_rev(fname:intel/06-4e-03;cpuid:000406e3;pf_mask:0xc0) = 0xdc
iucode_rev(fname:intel/06-4e-03;platform_id:0x40) = 0xdc
iucode_rev(fname:intel/06-4e-03;platform_id:0x80) = 0xdc

[root@intel-skylake-y-01 ~]# echo 1 > /sys/devices/system/cpu/microcode/reload

[root@intel-skylake-y-01 ~]# cat /sys/devices/system/cpu/cpu0/microcode/version 
0xdc

[root@intel-skylake-y-01 ~]# dracut --force --early-microcode

[root@intel-skylake-y-01 ~]# reboot
...

<<<HANG AFTER GRUB SCREEN>>>


Version-Release number of selected component (if applicable):
microcode_ctl-20191115-4.20200602.2.el8_2.x86_64

How reproducible:
always

Steps to Reproduce:
1. install RHEL-8.2.0
2. apply z-stream update to microcode_ctl-20191115-4.20200602.2.el8_2.x86_64
3. dracut --force --early-ucode
4. reboot

Actual results:
hang after grub

Expected results:
normal boot

Additional info:
Upstream bug report:
https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/issues/31

Comment 1 Eugene Syromiatnikov 2020-06-16 17:44:14 UTC
06-5e-03 is to be blacklisted as well per [1].

[1] https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/issues/31#issuecomment-644885826

Comment 5 Jeff Bastian 2020-06-22 19:06:28 UTC
Verified with microcode_ctl-1.17-33.29.el6_10.

The failed tasks are due to blacklisted CPUs which means they are not running the newest microcode revision.  In other words, the failures are expected and a good thing since it means the blacklist is working.

https://beaker.engineering.redhat.com/matrix/?whiteboard_filter=&job_ids=4372080%0D%0A4372125&toggle_nacks_on=on

Comment 7 errata-xmlrpc 2020-06-24 17:47:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:2742


Note You need to log in before you can comment on or make changes to this bug.