Bug 1846242 - [abrt] RHEL 7.7 gnome-shell: get_top_visible_window_actor(): gnome-shell killed by SIGSEGV
Summary: [abrt] RHEL 7.7 gnome-shell: get_top_visible_window_actor(): gnome-shell kill...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter
Version: 7.7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jonas Ådahl
QA Contact: Desktop QE
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:981667856fb16f251f0d3969101...
Depends On: 1788953
Blocks: 1847203
TreeView+ depends on / blocked
 
Reported: 2020-06-11 07:54 UTC by yzheng
Modified: 2020-11-03 02:30 UTC (History)
12 users (show)

Fixed In Version: mutter-3.28.3-26.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1788953
: 1847203 (view as bug list)
Environment:
Last Closed: 2020-09-29 20:22:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
touch-test.tar.xz (1.87 KB, application/x-xz)
2020-06-22 09:26 UTC, Jonas Ådahl
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/mutter - issues 338 0 None None None 2020-06-11 11:55:04 UTC
GNOME Gitlab GNOME/mutter - merge_requests 1317 0 None None None 2020-06-15 21:42:02 UTC
Red Hat Knowledge Base (Solution) 5504601 0 None None None 2020-11-03 02:30:20 UTC
Red Hat Product Errata RHBA-2020:3987 0 None None None 2020-09-29 20:22:56 UTC

Description yzheng 2020-06-11 07:54:48 UTC
+++ This bug was initially created as a clone of Bug #1788953 +++

Version-Release number of selected component:
gnome-shell-3.28.3-14.el7_7.x86_64

Additional info:
reporter:       
backtrace_rating: 
cgroup:         
11:perf_event:/
10:pids:/user.slice
9:cpuset:/
8:memory:/
7:hugetlb:/
6:cpuacct,cpu:/
5:blkio:/
4:devices:/user.slice
3:freezer:/
2:net_prio,net_cls:/
1:name=systemd:/user.slice/user-1000.slice/session-1.scope
cmdline:        /usr/bin/gnome-shell
crash_function: 
executable:     /usr/bin/gnome-shell
journald_cursor: 
kernel:         3.10.0-1062.12.1.el7.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
#0  meta_window_get_buffer_rect (window=0x0, rect=rect@entry=0x7ffd7fc62e40) at core/window.c:4396
#1  0x00007f1e2634837f in get_top_visible_window_actor (compositor=0x297d700, compositor=0x297d700) at compositor/compositor.c:1059
#2  meta_compositor_sync_stack (compositor=0x297d700, stack=<optimized out>, stack@entry=0x26e3140) at compositor/compositor.c:1176
#3  0x00007f1e263757ac in meta_stack_tracker_sync_stack (tracker=0x297dbc0) at core/stack-tracker.c:871
#4  0x00007f1e26375899 in stack_tracker_sync_stack_later (data=<optimized out>) at core/stack-tracker.c:881
#5  0x00007f1e26376914 in run_repaint_laters (laters_list=0x7f1e2663b7d8 <laters+24>) at core/util.c:809
#6  run_all_repaint_laters (data=<optimized out>) at core/util.c:826
#7  0x00007f1e26b18325 in _clutter_run_repaint_functions (flags=flags@entry=CLUTTER_REPAINT_FLAGS_PRE_PAINT) at clutter-main.c:3448
#8  0x00007f1e26b18fc5 in master_clock_update_stages (master_clock=0x32d6a80, stages=0x4e5a740) at clutter-master-clock-default.c:437
#9  clutter_clock_dispatch (source=<optimized out>, callback=<optimized out>, user_data=<optimized out>) at clutter-master-clock-default.c:567
#10 0x00007f1e27e48049 in g_main_dispatch (context=0x225b8d0) at gmain.c:3175
#11 g_main_context_dispatch (context=context@entry=0x225b8d0) at gmain.c:3828
#12 0x00007f1e27e483a8 in g_main_context_iterate (context=0x225b8d0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3901
#13 0x00007f1e27e4867a in g_main_loop_run (loop=0x24e29f0) at gmain.c:4097
#14 0x00007f1e2636a3dc in meta_run () at core/main.c:666
#15 0x000000000040219c in main (argc=1, argv=0x7ffd7fc63238) at ../src/main.c:534

Comment 11 Jonas Ådahl 2020-06-22 09:26:24 UTC
Created attachment 1698268 [details]
touch-test.tar.xz

Attaching a script that can be used to reproduce the issue.

Instructions:

 1. Unpack the tar.xz file
 2. Create the emulated device (see README.touch)
 3. Run the touch sequence from the 'touch-events' file (see README.touch)

The touch events defined in that file will touch on the left half of the screen, then right, and back and forth, quickly, for a long time.

Comment 12 Michael Boisvert 2020-06-22 14:13:40 UTC
I tested the scratch build provided using the randomization script also provided. After 30+ mins I do not see any crash in gnome, so its safe to proceed.

Comment 16 Michael Boisvert 2020-06-23 13:00:03 UTC
Testing the official build of mutter-3.28.3-26.el7, I experience no shell crashes with normal use and the randomized touch input script.

Comment 20 errata-xmlrpc 2020-09-29 20:22:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (GNOME bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3987


Note You need to log in before you can comment on or make changes to this bug.