Bug 1846398 - Removing JDBC connector for berkeleydb(libdb)
Summary: Removing JDBC connector for berkeleydb(libdb)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libdb
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Ondrej Dubaj
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1834842
TreeView+ depends on / blocked
 
Reported: 2020-06-11 13:46 UTC by Ondrej Dubaj
Modified: 2020-07-15 09:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-15 05:57:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Ondrej Dubaj 2020-06-11 13:46:19 UTC
Description of problem:
We are aiming to remove libdb-java package, as we are currently preparing for jdk update from jdk-1.8 to jdk-11 in Fedora rawhide. The problem is that we are unable to rebuild this package with jdk-11. It is still possible to "hack" it and rebuild it with jdk-1.8, but that can cause unexpected runtime behaviour according to JVM-11, which will soon be the default jdk in Fedora-rawhide.

There seems to be no packages, which depend directly to libdb-java and upstream does not support version 5.3.28 anymore.

Version-Release number of selected component (if applicable):

libdb-java-5.3.28-40
libdb-java-devel-5.3.28-40

Comment 1 Ondrej Dubaj 2020-06-24 09:49:39 UTC
Issue resolved here:

https://src.fedoraproject.org/rpms/libdb/pull-request/1

Successful build here:

https://koji.fedoraproject.org/koji/taskinfo?taskID=46082165

Comment 2 Honza Horak 2020-07-14 13:43:12 UTC
(In reply to Ondrej Dubaj from comment #1)
> https://src.fedoraproject.org/rpms/libdb/pull-request/1
Merged.

Comment 3 Ondrej Dubaj 2020-07-15 05:57:12 UTC
Issue resolved in f33

Comment 4 Honza Horak 2020-07-15 09:04:52 UTC
There is also an option to include Obsoletes and make the java sub-packages disappear without user notice. We did not consider this a good way to go, and rather leave the Java packages installed. At some point, the RPM metadata break and further update will not be possible, but at least user will explicitly remove the packages, which looks like a better option than doing it without them noticing. If anybody sees problem with this solution, please, re-open this bug and share your worry.


Note You need to log in before you can comment on or make changes to this bug.