Bug 1846451 - Backport upstream CPU Manager fix 90419 [4.5.z]
Summary: Backport upstream CPU Manager fix 90419 [4.5.z]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Artyom
QA Contact: Cameron Meadors
URL:
Whiteboard:
Depends On: 1846428
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-11 15:37 UTC by Victor Pickard
Modified: 2020-10-26 15:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1846428
Environment:
Last Closed: 2020-10-26 15:11:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25310 0 None closed [release-4.5] Bug 1846451: UPSTREAM: 90419: update strategy used to reuse CPUs from init containers in CPUManager 2020-11-03 16:56:18 UTC
Red Hat Product Errata RHBA-2020:4268 0 None None None 2020-10-26 15:12:16 UTC

Description Victor Pickard 2020-06-11 15:37:02 UTC
+++ This bug was initially created as a clone of Bug #1846428 +++

Description of problem:

Backport upstream fix for CPU Manager init containers 

https://github.com/kubernetes/kubernetes/pull/90419 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 12 Cameron Meadors 2020-10-20 18:41:14 UTC
cpumanager behavior is correct.  It matches y stream fix behavior with no regressions.

Comment 14 errata-xmlrpc 2020-10-26 15:11:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.16 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4268


Note You need to log in before you can comment on or make changes to this bug.