Bug 1846596 - Package ovirt-host has dependency to katello-agent
Summary: Package ovirt-host has dependency to katello-agent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-host
Version: 4.3.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-4.4.1
: 4.4.1
Assignee: Sandro Bonazzola
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-12 06:46 UTC by Stefan Meyer
Modified: 2020-08-04 13:28 UTC (History)
4 users (show)

Fixed In Version: ovirt-host-4.4.0
Doc Type: Removed functionality
Doc Text:
In previous versions, the katello-agent package was automatically installed on all hosts as a dependency of the ovirt-host package. The current release, RHV 4.4 removes this dependency to reflect the removal of the katello-agent from Satellite 6.7. Instead, you can now use katello-host-tools, which enables users to install the correct agent for their version of Satellite.
Clone Of:
Environment:
Last Closed: 2020-08-04 13:28:34 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:3246 0 None None None 2020-08-04 13:28:50 UTC

Description Stefan Meyer 2020-06-12 06:46:27 UTC
Description of problem:
The ovirt-host package has a dependency to katello-agent.
As the katello-agent is deprecated with Satellite 7 the dependency should be removed.

Version-Release number of selected component (if applicable):
ovirt-host-4.3.5-1.el7ev.x86_64

How reproducible:
- Evertime


Steps to Reproduce:
1. By removing the package katello-agent


Actual results:
- Removing the katello-agent package will also remove the ovirt-host as dependency


Expected results:
- Removing the katello-agent package should not remove the ovirt-host


Additional info:
Please also check if the ipa-client and openscap is also required.
Not all customers are using ipa and openscap and we should only 
install packages that are really required to run the ovirt-host.

Comment 1 Sandro Bonazzola 2020-06-15 13:11:15 UTC
Already dropped in oVirt 4.4.0

Comment 2 Pavol Brilla 2020-06-26 12:30:40 UTC
# yum deplist ovirt-host-4.4.1-2.el8ev.x86_64 | grep -E "katello-agent|tmux"
Last metadata expiration check: 0:41:35 ago on Fri 26 Jun 2020 01:48:40 PM CEST.
  dependency: tmux
   provider: tmux-2.7-1.el8.x86_64
   provider: tmux-2.7-1.el8.x86_64

Comment 8 errata-xmlrpc 2020-08-04 13:28:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (RHV RHEL Host (ovirt-host) 4.4), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:3246


Note You need to log in before you can comment on or make changes to this bug.