Bug 1846977 - `oc explain bmh` returns empty description
Summary: `oc explain bmh` returns empty description
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Doug Hellmann
QA Contact: Polina Rabinovich
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-15 10:04 UTC by MinLi
Modified: 2020-10-27 16:07 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:07:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift baremetal-operator pull 88 0 None closed sync upstream changes 2020-07-29 2021-01-08 12:06:06 UTC
Github openshift machine-api-operator pull 661 0 None closed Bug 1854142: update baremetalhost crd to apiextensions.k8s.io/v1 2021-01-08 12:05:29 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:07:38 UTC

Description MinLi 2020-06-15 10:04:25 UTC
Description of problem:
`oc explain bmh` returns empty description

Version-Release number of selected component (if applicable):
$ oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-06-11-183238   True        False         32m     Cluster version is 4.5.0-0.nightly-2020-06-11-183238


How reproducible:
always

Steps to Reproduce:
1.oc explain bmh
2.
3.

Actual results:
$ oc explain bmh
KIND:     BareMetalHost
VERSION:  metal3.io/v1alpha1

DESCRIPTION:
     <empty>


Expected results:
Should return detailed description and related fields explanation.

Additional info:

Comment 1 MinLi 2020-06-15 10:37:21 UTC
$ oc version 
Client Version: 4.5.0-202005291417-9933eb9

Comment 2 Maciej Szulik 2020-06-15 14:32:48 UTC
Each API is responsible for providing their own description, thus moving accordingly to bare metal team to update their API.

Comment 8 Polina Rabinovich 2020-09-22 08:27:00 UTC
Verified in virtual baremetal disconnected setup with IPv6 provisioning, and IPv6 baremetal network:

[kni@provisionhost-0-0 ~]$ oc explain bmh
KIND:     BareMetalHost
VERSION:  metal3.io/v1alpha1

DESCRIPTION:
     BareMetalHost is the Schema for the baremetalhosts API

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#types-kinds

   metadata	<Object>
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#metadata

   spec	<Object>
     BareMetalHostSpec defines the desired state of BareMetalHost

   status	<Object>
     BareMetalHostStatus defines the observed state of BareMetalHost

Comment 11 errata-xmlrpc 2020-10-27 16:07:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.