Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 18471 - traceroute with PPPoE
traceroute with PPPoE
Status: CLOSED DUPLICATE of bug 17915
Product: Red Hat Linux
Classification: Retired
Component: traceroute (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-05 17:28 EDT by Daniel Meynen
Modified: 2007-04-18 12:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-05 17:49:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Meynen 2000-10-05 17:28:46 EDT
The version of traceroute-1.4a5-23.i386 doesn't work when connection is
made with pppoe (rp-pppoe-2.2-4.i386).

I can only use traceroute to find my own machine, but not another one on
the Internet.

But traceroute works right if I use the -s option in the command line,
like:

# traceroute -s xxx.xxx.xxx.xxx bugzilla.redhat.com

where xxx.xxx.xxx.xxx is the IP address of the ppp0 interface.

Daniel Meynen
Comment 1 Daniel Roesen 2000-10-10 11:12:59 EDT

*** This bug has been marked as a duplicate of 17915 ***
Comment 2 Phil 2000-10-31 00:28:07 EST
after upgrading to rh7.0 & traceroute-1.4a5-23, a traceroute to 
redhat.com/internet uses the correct interface ppp0 but a private internal 
source of 192.168.0.x. which is impossible.  route table is correct with a 
default to internet gateway and ppp0 if.  downgrading to traceroute-1.4a5-18 
fixed this for me.  using rp-pppoe-2.3-1.  you'd think traceroute would use the 
route table no?  doesn't seem to.

Note You need to log in before you can comment on or make changes to this bug.