Bug 1847157 - Duplicate ID attributed in affinity modal inputs
Summary: Duplicate ID attributed in affinity modal inputs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Yaacov Zamir
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-15 19:20 UTC by Radim Hrazdil
Modified: 2020-10-27 16:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:07:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (465.35 KB, image/png)
2020-06-15 19:20 UTC, Radim Hrazdil
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5813 0 None closed Bug 1847157: Add a prefix to the ids of affinity row edit 2020-06-30 10:01:11 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:07:38 UTC

Description Radim Hrazdil 2020-06-15 19:20:22 UTC
Created attachment 1697512 [details]
screenshot

Description of problem:
ID attributes in affinity modal inputs have the same form for Node labels and Node Fields rows: `affinity-${id}-key-input`

The problem is that the id is indexed from 0 for both sections (labels and field rows), which results in duplicated IDs.


Version-Release number of selected component (if applicable):
4.5

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Guohua Ouyang 2020-06-30 10:04:43 UTC
they are "affinity-expression-0-key-input" and "affinity-field-0-key-input" now.
verified on upstream 4.6 branch.

Comment 5 errata-xmlrpc 2020-10-27 16:07:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.