Bug 1847349 - RHCOS version is not correct for OCP 4.6
Summary: RHCOS version is not correct for OCP 4.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.6.0
Assignee: Micah Abbott
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-16 09:18 UTC by MinLi
Modified: 2020-10-27 16:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:07:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:08:00 UTC

Description MinLi 2020-06-16 09:18:09 UTC
Description of problem:
RHCOS version is not correct for OCP 4.6

Version-Release number of selected component (if applicable):
 oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-06-16-005956   True        False         3h16m   Cluster version is 4.6.0-0.nightly-2020-06-16-005956


How reproducible:
always

Steps to Reproduce:
1.$ oc get node -o wide
2.check /etc/os-release and /etc/redhat-release
3.

Actual results:
1.$ oc get node -o wide 
NAME                                         STATUS   ROLES    AGE     VERSION           INTERNAL-IP    EXTERNAL-IP   OS-IMAGE                                      KERNEL-VERSION          CONTAINER-RUNTIME
ip-10-0-128-113.us-east-2.compute.internal   Ready    master   3h45m   v1.18.3+295a35c   10.0.128.113   <none>        Red Hat Enterprise Linux CoreOS 4.5 (Ootpa)   4.18.0-211.el8.x86_64   cri-o://1.19.0-19.dev.rhaos4.6.git3f327dc.el8-dev
ip-10-0-153-238.us-east-2.compute.internal   Ready    worker   3h34m   v1.18.3+295a35c   10.0.153.238   <none>        Red Hat Enterprise Linux CoreOS 4.5 (Ootpa)   4.18.0-211.el8.x86_64   cri-o://1.19.0-19.dev.rhaos4.6.git3f327dc.el8-dev
ip-10-0-163-157.us-east-2.compute.internal   Ready    master   3h45m   v1.18.3+295a35c   10.0.163.157   <none>        Red Hat Enterprise Linux CoreOS 4.5 (Ootpa)   4.18.0-211.el8.x86_64   cri-o://1.19.0-19.dev.rhaos4.6.git3f327dc.el8-dev
ip-10-0-181-72.us-east-2.compute.internal    Ready    worker   3h35m   v1.18.3+295a35c   10.0.181.72    <none>        Red Hat Enterprise Linux CoreOS 4.5 (Ootpa)   4.18.0-211.el8.x86_64   cri-o://1.19.0-19.dev.rhaos4.6.git3f327dc.el8-dev
ip-10-0-207-79.us-east-2.compute.internal    Ready    master   3h45m   v1.18.3+295a35c   10.0.207.79    <none>        Red Hat Enterprise Linux CoreOS 4.5 (Ootpa)   4.18.0-211.el8.x86_64   cri-o://1.19.0-19.dev.rhaos4.6.git3f327dc.el8-dev

2.
sh-4.4# cat /etc/redhat-release 
Red Hat Enterprise Linux CoreOS release 4.5

sh-4.4# cat /etc/os-release     
NAME="Red Hat Enterprise Linux CoreOS"
VERSION="4.5"
VERSION_ID="4.5"
OPENSHIFT_VERSION="4.5"
RHEL_VERSION="8.2"
PRETTY_NAME="Red Hat Enterprise Linux CoreOS 4.5 (Ootpa)"
ID="rhcos"
ID_LIKE="rhel fedora"
ANSI_COLOR="0;31"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="OpenShift Container Platform"
REDHAT_BUGZILLA_PRODUCT_VERSION="4.5"
REDHAT_SUPPORT_PRODUCT="OpenShift Container Platform"
REDHAT_SUPPORT_PRODUCT_VERSION="4.5"
OSTREE_VERSION='46.82.202006152120-0'


Expected results:
RHCOS version should be 4.6

Additional info:

Comment 2 Micah Abbott 2020-06-16 19:34:33 UTC
Latest 4.6 nightly:

```
$ oc image info --output json $(oc adm release info -a ~/openshift-cluster-installs/all-the-pull-secrets.json --image-for=machine-os-content  registry.svc.ci.openshift.org/ocp/release:4.6.0-0.nightly-2020-06-16-165419) | jq .config.config.Labels.version
"46.82.202006161324-0"
```

Booting a single RHCOS node from that version:

```
$ coreos-assembler run --qemu-image ./rhcos-46.82.202006161324-0-qemu.x86_64.qcow2 
+ chrt --idle 0 podman run --rm -ti --security-opt label=disable --privileged --uidmap=1000:0:1 --uidmap=0:1:1000 --uidmap 1001:1001:64536 -v /var/home/miabbott/redhat-coreos:/srv/ --device /dev/kvm --device /dev/fuse --tmpfs /tmp -v /var/tmp:/var/tmp --name coreos-assembler quay.io2
virtio journal connected - sshd started
Warning: Permanently added '[127.0.0.1]:43767' (ECDSA) to the list of known hosts.
Red Hat Enterprise Linux CoreOS 4.5
  Part of OpenShift 4.5, RHCOS is a Kubernetes native operating system
  managed by the Machine Config Operator (`clusteroperator/machine-config`).

WARNING: Direct SSH access to machines is not recommended; instead,
make configuration changes via `machineconfig` objects:
  https://docs.openshift.com/container-platform/4.5/architecture/architecture-rhcos.html

---
Last login: Tue Jun 16 19:33:18 2020
[core@cosa-devsh ~]$ cat /etc/os-release 
NAME="Red Hat Enterprise Linux CoreOS"
VERSION="4.5"
VERSION_ID="4.5"
OPENSHIFT_VERSION="4.5"
RHEL_VERSION="8.2"
PRETTY_NAME="Red Hat Enterprise Linux CoreOS 4.5 (Ootpa)"
ID="rhcos"
ID_LIKE="rhel fedora"
ANSI_COLOR="0;31"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="OpenShift Container Platform"
REDHAT_BUGZILLA_PRODUCT_VERSION="4.5"
REDHAT_SUPPORT_PRODUCT="OpenShift Container Platform"
REDHAT_SUPPORT_PRODUCT_VERSION="4.5"
OSTREE_VERSION='46.82.202006161324-0'
[core@cosa-devsh ~]$ rpm -q redhat-release-coreos
redhat-release-coreos-45.82-5.el8.x86_64
```

So we need to get the 4.6 version of redhat-release-coreos built and tagged properly.

Comment 3 Colin Walters 2020-06-16 20:34:12 UTC
Something is wrong with the ART tags or something:
https://coreos.slack.com/archives/CB95J6R4N/p1592339605407000

Comment 4 Micah Abbott 2020-06-19 22:43:14 UTC
This landed in `redhat-release-coreos-46.82-2.el8.x86_64` should be included in latest 4.6 nightly payloads.

```
$ rpm-ostree status -b
State: idle
BootedDeployment:
* ostree://7858a6e67a225e03ff54e301010c69d5ffb2ab22ecb42c99adef747b92c38016
                   Version: 46.82.202006190240-0 (2020-06-19T02:44:38Z)
[core@cosa-devsh ~]$ rpm -q redhat-release-coreos  
redhat-release-coreos-46.82-2.el8.x86_64
[core@cosa-devsh ~]$ cat /etc/os-release 
NAME="Red Hat Enterprise Linux CoreOS"
VERSION="46.82.202006190240-0"
VERSION_ID="4.6"
OPENSHIFT_VERSION="4.6"
RHEL_VERSION="8.2"
PRETTY_NAME="Red Hat Enterprise Linux CoreOS 46.82.202006190240-0 (Ootpa)"
ID="rhcos"
ID_LIKE="rhel fedora"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:8::coreos"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="OpenShift Container Platform"
REDHAT_BUGZILLA_PRODUCT_VERSION="4.6"
REDHAT_SUPPORT_PRODUCT="OpenShift Container Platform"
REDHAT_SUPPORT_PRODUCT_VERSION="4.6"
OSTREE_VERSION='46.82.202006190240-0'
```

Comment 7 MinLi 2020-06-23 09:08:40 UTC
verified with version : 4.6.0-0.nightly-2020-06-20-011219

$ oc get node -o wide 
NAME                                         STATUS   ROLES    AGE   VERSION           INTERNAL-IP    EXTERNAL-IP   OS-IMAGE                                                       KERNEL-VERSION          CONTAINER-RUNTIME
ip-10-0-145-110.us-east-2.compute.internal   Ready    worker   30h   v1.18.3+e1ba7b6   10.0.145.110   <none>        Red Hat Enterprise Linux CoreOS 46.82.202006192241-0 (Ootpa)   4.18.0-211.el8.x86_64   cri-o://1.19.0-23.dev.rhaos4.6.git6902246.el8-dev
ip-10-0-155-105.us-east-2.compute.internal   Ready    master   30h   v1.18.3+e1ba7b6   10.0.155.105   <none>        Red Hat Enterprise Linux CoreOS 46.82.202006192241-0 (Ootpa)   4.18.0-211.el8.x86_64   cri-o://1.19.0-23.dev.rhaos4.6.git6902246.el8-dev

sh-4.4# cat /etc/redhat-release 
Red Hat Enterprise Linux CoreOS release 4.6

sh-4.4# cat /etc/os-release 
NAME="Red Hat Enterprise Linux CoreOS"
VERSION="46.82.202006192241-0"
VERSION_ID="4.6"
OPENSHIFT_VERSION="4.6"
RHEL_VERSION="8.2"
PRETTY_NAME="Red Hat Enterprise Linux CoreOS 46.82.202006192241-0 (Ootpa)"
ID="rhcos"
ID_LIKE="rhel fedora"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:8::coreos"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="OpenShift Container Platform"
REDHAT_BUGZILLA_PRODUCT_VERSION="4.6"
REDHAT_SUPPORT_PRODUCT="OpenShift Container Platform"
REDHAT_SUPPORT_PRODUCT_VERSION="4.6"
OSTREE_VERSION='46.82.202006192241-0'

Comment 9 errata-xmlrpc 2020-10-27 16:07:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.