Bug 1847363 - centos7 image missing
Summary: centos7 image missing
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Multi-Arch
Version: 4.3.z
Hardware: s390x
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Rafael Fonseca
QA Contact: Barry Donahue
URL:
Whiteboard: multi-arch
Depends On:
Blocks: 1882454 ocp-42-45-z-tracker
TreeView+ depends on / blocked
 
Reported: 2020-06-16 09:36 UTC by Rafael Fonseca
Modified: 2020-12-07 17:05 UTC (History)
3 users (show)

Fixed In Version: 4.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-04 15:42:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 24887 0 None closed Bug 1816812: Enable mirroring test images offline 2020-12-15 23:27:45 UTC
Github openshift origin pull 25491 0 None closed Bug 1847363: test: use ubi instead of centos 2020-12-15 23:27:44 UTC
Github openshift origin pull 25721 0 None closed Bug 1902029: move off docker.io in build e2e's (approximate recent 4.7 changes) 2020-12-15 23:27:44 UTC

Description Rafael Fonseca 2020-06-16 09:36:59 UTC
Description of problem: some tests fail because there is no centos7 image for s390x


Version-Release number of selected component (if applicable): 4.3, 4.4, 4.5


How reproducible: Always


Steps to Reproduce: Openshift CI


Additional info:

4.5 tests:
[sig-builds][Feature:Builds] Optimized image builds should succeed [Suite:openshift/conformance/parallel]
[sig-instrumentation] Prometheus when installed on the cluster shouldn't report any alerts in firing state apart from Watchdog and AlertmanagerReceiversNotConfigured [Early] [Suite:openshift/conformance/parallel]

Comment 2 Yaakov Selkowitz 2020-08-13 20:13:37 UTC
Can you point to the sources for the test in question?  Is modifying the test to use ubi8 an option?

Comment 4 Rafael Fonseca 2020-08-18 14:00:42 UTC
https://github.com/openshift/origin/pull/25014

Comment 8 Dan Li 2020-12-02 15:47:59 UTC
Adding UpcomingSprint tag as team will not have bandwidth to resolve this bug

Comment 9 Rafael Fonseca 2020-12-02 15:54:44 UTC
This upstream PR replaces some more centos usage https://github.com/openshift/origin/pull/25721

Comment 10 Rafael Fonseca 2020-12-04 15:42:32 UTC
Upstream PR #24887 linked in this issue resolves this problem as a side effect. PR #25721 is the current effort to backport those changes to ocp-4.6.

Since this issue affects only CI and I don't see backports being applied to any version older than 4.6, I'm closing this bug.


Note You need to log in before you can comment on or make changes to this bug.