Bug 1847450 - Show only one Kibana Console Link in App Navbar
Summary: Show only one Kibana Console Link in App Navbar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Periklis Tsirakidis
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks: 1848271
TreeView+ depends on / blocked
 
Reported: 2020-06-16 12:07 UTC by Periklis Tsirakidis
Modified: 2020-10-27 16:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:07:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift elasticsearch-operator pull 398 0 None closed Bug 1847450: Publish only one console link for Kibana 2020-08-28 06:32:32 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:08:00 UTC

Description Periklis Tsirakidis 2020-06-16 12:07:05 UTC
Description of problem:
We used to publish two links via ConsoleLink CR for kibana without specific distinction which link is for the Admin and which for the Developer view. Since the links are published by the web console in the new App Navbar ([1]), this results in two identical links. 

Expected Behavior:
Publish only on link for Kibana on the App navbar.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1840478#c1

Comment 1 Jeff Cantrill 2020-06-16 13:56:10 UTC
Needs a 4.5.z backport

Comment 5 errata-xmlrpc 2020-10-27 16:07:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.