Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 18477 - chkconfig --del and --add don't work with xinetd service
chkconfig --del and --add don't work with xinetd service
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: chkconfig (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-05 18:38 EDT by Joshua Jensen
Modified: 2014-03-16 22:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-05 18:46:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2000-10-05 18:38:33 EDT
Not sure if this is a but or not:, but:

[root@joshua /root]# head -1 /etc/xinetd.d/telnet 
# default: on
[root@joshua /root]# grep disable /etc/xinetd.d/telnet
        disable = no
[root@joshua /root]# chkconfig --del telnet
[root@joshua /root]# grep disable /etc/xinetd.d/telnet
        disable = no
[root@joshua /root]# chkconfig --add telnet
[root@joshua /root]# grep disable /etc/xinetd.d/telnet
        disable = no

The man page for chkconfig doesn't mention xinetd services, so I'm not sure
if this is a bug or not.

I see that "chkconfig telnet on" works, even though using "on" without
--level should turn on a service in runlevels 3, 4, and 5.  Since --del and
--add work with the *defined* run-levels as specified by the " #chkconfig:"
lines in /etc/rc.d/init.d/ files, it should (IMHO) work for xinetd services
in simlary fashion (as defined by the "# default: on" line).
Comment 1 Bill Nottingham 2000-10-19 02:30:57 EDT
--add adds the default chkconfig links (i.e, S20foo, K80foo).
--del removes them.

Since there are no links to add/remove for xinetd services,
--add and --del don't do anything for them (similarly, since
xinetd doesn't keep track of runlevels, the --level directive
is ignored for xinetd services.)

Note You need to log in before you can comment on or make changes to this bug.