Bug 1847740 - openshift-marketplace: Pods found with invalid container images not present in release payload (v2)
Summary: openshift-marketplace: Pods found with invalid container images not present i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.z
Assignee: Kevin Rizza
QA Contact: Salvatore Colangelo
URL:
Whiteboard:
: 1840709 (view as bug list)
Depends On: 1845644
Blocks: 1849153
TreeView+ depends on / blocked
 
Reported: 2020-06-16 22:06 UTC by OpenShift BugZilla Robot
Modified: 2020-06-29 15:34 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-29 15:34:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-marketplace pull 315 None closed [release-4.4] [release-4.5] Bug 1847740: Ensure correct registry image 2020-09-16 16:10:18 UTC
Red Hat Product Errata RHBA-2020:2713 None None None 2020-06-29 15:34:43 UTC

Comment 4 Salvatore Colangelo 2020-06-22 13:38:13 UTC
[scolange@scolange operator-registry]$ oc exec marketplace-operator-664774d49-jhqkf -n openshift-marketplace -- marketplace-operator --version
Marketplace source git commit: 01f5538293c300c97ea5b045d60981243bc24c30
time="2020-06-22T13:28:32Z" level=info msg="Go Version: go1.13.4"
time="2020-06-22T13:28:32Z" level=info msg="Go OS/Arch: linux/amd64"
time="2020-06-22T13:28:32Z" level=info msg="operator-sdk Version: v0.8.0"

[scolange@scolange operator-registry]$ oc project openshift-marketplace
Now using project "openshift-marketplace" on server "https://api.qe-jiazha22.qe.devcluster.openshift.com:6443".

[scolange@scolange operator-registry]$ oc get pod -n openshift-marketplace

[scolange@scolange operator-registry]$ oc get pod
NAME                                   READY   STATUS    RESTARTS   AGE
certified-operators-79bdb7b994-mq2jg   1/1     Running   0          80m
community-operators-84c5574565-snwzj   1/1     Running   0          10h
marketplace-operator-664774d49-jhqkf   1/1     Running   0          10h
qe-app-registry-64b87679c8-chmmn       1/1     Running   0          20m
redhat-marketplace-6c48857d6b-zstmb    1/1     Running   0          80m
redhat-operators-6bc7cd8565-m46vq      1/1     Running   0          10h
simplecsc2-7449c47b64-7r6sr            1/1     Running   0          4h1m

[scolange@scolange operator-registry]$ oc exec certified-operators-79bdb7b994-mq2jg -- cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.8 (Maipo)
[scolange@scolange operator-registry]$ oc exec community-operators-84c5574565-snwzj -- cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.8 (Maipo)
[scolange@scolange operator-registry]$ oc exec marketplace-operator-664774d49-jhqkf -- cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.8 (Maipo)
[scolange@scolange operator-registry]$ oc exec qe-app-registry-64b87679c8-chmmn -- cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.8 (Maipo)
[scolange@scolange operator-registry]$ oc exec redhat-marketplace-6c48857d6b-zstmb -- cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.8 (Maipo)
[scolange@scolange operator-registry]$ oc exec redhat-operators-6bc7cd8565-m46vq -- cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.8 (Maipo)


All of them are downstream, LGTM, verify it.

Comment 6 Nicolas Nosenzo 2020-06-25 14:11:05 UTC
*** Bug 1840709 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2020-06-29 15:34:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2713


Note You need to log in before you can comment on or make changes to this bug.