Bug 1847860 (CVE-2020-14296) - CVE-2020-14296 CloudForms: Server-Side Request Forgery (SSRF) in Ansible Tower Provider
Summary: CVE-2020-14296 CloudForms: Server-Side Request Forgery (SSRF) in Ansible Towe...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2020-14296
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1847862
Blocks: 1847854
TreeView+ depends on / blocked
 
Reported: 2020-06-17 08:49 UTC by Yadnyawalk Tale
Modified: 2021-02-16 19:52 UTC (History)
11 users (show)

Fixed In Version: cfme 5.11.7.0
Doc Type: If docs needed, set a value
Doc Text:
A Server-Side Request Forgery flaw was found in Red Hat CloudForms where malicious requests can be sent from the vulnerable server. An attacker with the privileges to add Ansible Tower provider could inject URLs with port details or with internal IPs to observe internal network.
Clone Of:
Environment:
Last Closed: 2020-08-06 19:27:57 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2020:3358 0 None None None 2020-08-06 14:32:46 UTC

Description Yadnyawalk Tale 2020-06-17 08:49:30 UTC
Red Hat CloudForms 4.7 and 5 was vulnerable to Server-Side Request Forgery (SSRF) flaw. With the access to add Ansible Tower provider, an attacker could scan and attack systems from the internal network which are not normally accessible.

Comment 4 Yadnyawalk Tale 2020-06-24 17:28:22 UTC
Acknowledgments:

Name: Purnachand Pulahari (IBM), Ranjit Kumar Singh (IBM)

Comment 5 Yadnyawalk Tale 2020-07-13 15:22:13 UTC
Mitigation:

Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.

Comment 7 errata-xmlrpc 2020-08-06 14:32:45 UTC
This issue has been addressed in the following products:

  CloudForms Management Engine 5.11

Via RHSA-2020:3358 https://access.redhat.com/errata/RHSA-2020:3358

Comment 8 Product Security DevOps Team 2020-08-06 19:27:57 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2020-14296


Note You need to log in before you can comment on or make changes to this bug.