Bug 1847886 - machine-os-content image has a wrong display label resulting in payload builds failing
Summary: machine-os-content image has a wrong display label resulting in payload build...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Colin Walters
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-17 09:45 UTC by Standa Laznicka
Modified: 2020-10-27 16:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:07:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github coreos coreos-assembler pull 1531 0 None closed upload-oscontainer: Automatically inject --display-name 2020-09-16 19:55:18 UTC
Github coreos coreos-assembler pull 1541 0 None closed upload-oscontainer: Correctly strip quotes from name 2020-09-16 19:55:18 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:07:56 UTC

Description Standa Laznicka 2020-06-17 09:45:36 UTC
Description of problem:
builds are failing with:
"""
error: unable to check whether to include image registry.svc.ci.openshift.org/ci-op-s773ycdd/stable@sha256:ba3d742559e5be7a466ee2c92823fadf7baa23836d84f9a9e8323ae30cc36dc1: tag "machine-os-content" has an invalid io.openshift.build.versions or io.openshift.build.version-display-names label: the display name "\"Red Hat Enterprise Linux CoreOS\"" must only be alphanumerics, spaces, and symbols in [():-]
"""

Version-Release number of selected component (if applicable):
4.6

How reproducible:
100%

Additional info:
see failing jobs in https://testgrid.k8s.io/redhat-openshift-ocp-release-4.6-informing#promote-release-openshift-machine-os-content-e2e-aws-4.6&sort-by-flakiness=, e.g. https://deck-ci.apps.ci.l2s4.p1.openshiftapps.com/view/gcs/origin-ci-test/logs/promote-release-openshift-machine-os-content-e2e-aws-4.6/1273121594801131520

Comment 1 Micah Abbott 2020-06-17 13:12:39 UTC
This is a regression from work to upstream our oscontainer upload functionality.  We have some PRs in flight to address this.

Comment 5 errata-xmlrpc 2020-10-27 16:07:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.