Bug 1847961 - error "label value was collected before with the same name and label values" in node-exporter pod's log
Summary: error "label value was collected before with the same name and label values" ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.4.z
Assignee: Pawel Krupa
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1846857 (view as bug list)
Depends On: 1803058
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-17 12:49 UTC by OpenShift BugZilla Robot
Modified: 2020-07-06 20:47 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-06 20:47:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift node_exporter pull 63 None closed [release-4.4] Bug 1847961: text_collectors: Don't detect AWS twice when virt-what is upgraded 2020-06-30 01:21:11 UTC
Red Hat Product Errata RHBA-2020:2786 None None None 2020-07-06 20:47:39 UTC

Comment 1 Pawel Krupa 2020-06-17 12:52:21 UTC
*** Bug 1846857 has been marked as a duplicate of this bug. ***

Comment 6 Junqi Zhao 2020-06-28 06:35:59 UTC
Issue is fixed with 4.4.0-0.nightly-2020-06-27-171816
# oc -n openshift-monitoring get pod -o wide | grep node-exporter
node-exporter-ddwpk                            2/2     Running   0          93m   10.0.198.116   ip-10-0-198-116.us-east-2.compute.internal   <none>           <none>
node-exporter-fwjsq                            2/2     Running   0          93m   10.0.178.102   ip-10-0-178-102.us-east-2.compute.internal   <none>           <none>
node-exporter-g5t76                            2/2     Running   0          97m   10.0.209.148   ip-10-0-209-148.us-east-2.compute.internal   <none>           <none>
node-exporter-kxlj2                            2/2     Running   0          97m   10.0.158.126   ip-10-0-158-126.us-east-2.compute.internal   <none>           <none>
node-exporter-spckf                            2/2     Running   0          97m   10.0.163.150   ip-10-0-163-150.us-east-2.compute.internal   <none>           <none>
node-exporter-t2rc5                            2/2     Running   0          93m   10.0.144.133   ip-10-0-144-133.us-east-2.compute.internal   <none>           <none>
# oc -n openshift-monitoring exec -c node-exporter node-exporter-ddwpk -- cat /var/node_exporter/textfile/virt.prom
# HELP virt_platform reports one series per detected virtualization type. If no type is detected, the type is "none".
# TYPE virt_platform gauge
virt_platform{type="xen"} 1
virt_platform{type="xen-hvm"} 1
virt_platform{type="aws"} 1

Comment 8 errata-xmlrpc 2020-07-06 20:47:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2786


Note You need to log in before you can comment on or make changes to this bug.