Bug 1847971 - A change in VM's boot order remove environment variable disks for VM yaml
Summary: A change in VM's boot order remove environment variable disks for VM yaml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.z
Assignee: Ido Rosenzwig
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On: 1847480
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-17 13:15 UTC by OpenShift BugZilla Robot
Modified: 2020-07-22 12:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-22 12:20:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5762 None closed [release-4.5.z] Bug 1847971: VM's boot order modal will not remove non-bootable disks 2020-07-20 02:28:34 UTC
Red Hat Product Errata RHBA-2020:2956 None None None 2020-07-22 12:21:08 UTC

Description OpenShift BugZilla Robot 2020-06-17 13:15:05 UTC
+++ This bug was initially created as a clone of Bug #1847480 +++

Description of problem:
Changing the VM's boot order causes the environment variable disks to be removed from the VM yaml which causes the Environment tab not to load.


How reproducible:
100%

Steps to Reproduce:
1. Create a VM from the WEB-UI (using the YAML)
2. Navigate to the Environment tab of the VM
3. Add one or more sources
4. navigate to the details tab
5. change the boot order ( add NIC )
6. navigate back to the Environment tab

Actual results:
page doesn't load, exception is thrown

Expected results:
the page should load we the sources you added in section 3

Additional info:

Comment 1 Tomas Jelinek 2020-07-10 05:38:21 UTC
patch ready, just waiting for 4.5.z to open to be merged.

Comment 4 Guohua Ouyang 2020-07-20 06:56:04 UTC
verified on upstream 4.5 branch which has PR #5762 included, the issue is fixed.

Comment 6 errata-xmlrpc 2020-07-22 12:20:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2956


Note You need to log in before you can comment on or make changes to this bug.