Bug 18481 - installation failuer
Summary: installation failuer
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brock Organ
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-05 23:42 UTC by Dimitrie O. Paun
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 15:21:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace as save by anaconda (759 bytes, text/plain)
2000-10-05 23:43 UTC, Dimitrie O. Paun
no flags Details

Description Dimitrie O. Paun 2000-10-05 23:42:52 UTC
I've partitioned my disk with fdisk, 
but when I got to the formatting step,
it complained that it does not see
the partitioned that I have created
with fdisk.

Note however, that it has seen them
before because I've set up the mount
point and all...

Indeed, I've shitched to the shell
console, and ls /dev did not list
those partitions.

Here is the backtrace that I've got:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in 
mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 19430617
fsystem: ext2
self: <fstab.GuiFstab instance at 84b94b8>
msg: Invalid argument
doFormat: 1
errno: 22
device: hdb3
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Dimitrie O. Paun 2000-10-05 23:43:58 UTC
Created attachment 3822 [details]
backtrace as save by anaconda

Comment 2 Michael Fulbright 2000-10-06 20:23:31 UTC
Did you format the '/' partition?

The device files for the partitions are created as required in the /tmp
directory, which is why you didn't see them in /dev.

Comment 3 Dimitrie O. Paun 2000-10-06 20:49:54 UTC
No, I did NOT format / -- the HD I installed to was brand new, so I fdisk-ed 
it, and proceeded with the install. When the installation process got to the 
point where it tried to format (or install the swap space, I forget), it craped 
out on me. A reboot solved the problem, becuase this time the disk was already 
partitioned.

Comment 4 Michael Fulbright 2000-11-07 19:42:47 UTC
Passed to QA to verify this issue:

   Take a hard drive and wipe the partitioning table to all zeros.

   Partition the drive as indicated in this report, and see if this problem is
reproduced.

Comment 5 Brock Organ 2000-11-13 16:56:57 UTC
hmmm ... we are unable to reproduce this problem w/generic test lab hardware
(trying what was described above, zero-ing out the entire drive and then
partitioning as described above)  what kind of drive do you have ...?

Comment 6 Michael Fulbright 2000-12-04 15:21:16 UTC
Please reopen this report if you continue to have problems.


Note You need to log in before you can comment on or make changes to this bug.