Bug 1848754 - [CI test code fix][sig-auth][Feature:ProjectAPI] TestProjectWatch should succeed [NEEDINFO]
Summary: [CI test code fix][sig-auth][Feature:ProjectAPI] TestProjectWatch should suc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.6.0
Assignee: Lukasz Szaszkiewicz
QA Contact: Xingxing Xia
URL:
Whiteboard: LifecycleReset
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-18 21:27 UTC by Sally
Modified: 2020-10-27 16:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
[sig-auth][Feature:ProjectAPI] TestProjectWatch should succeed
Last Closed: 2020-10-27 16:08:08 UTC
Target Upstream Version:
mfojtik: needinfo?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25515 0 None open Bug 1848754: TestProjectWatch should succeed 2020-09-17 13:53:46 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:08:29 UTC

Comment 1 Standa Laznicka 2020-06-19 12:29:45 UTC
The timeout for the last project deletion is set to 30 seconds, the last event observed is of the "MODIFIED" type and it shows setting the project's status to "Terminating". If the test is supposed to pass with deleting the project in under 30 seconds, this would be a performance issue of the openshift-apiserver.

Comment 3 Michal Fojtik 2020-08-24 13:12:12 UTC
This bug hasn't had any activity in the last 30 days. Maybe the problem got resolved, was a duplicate of something else, or became less pressing for some reason - or maybe it's still relevant but just hasn't been looked at yet. As such, we're marking this bug as "LifecycleStale" and decreasing the severity/priority. If you have further information on the current state of the bug, please update it, otherwise this bug can be closed in about 7 days. The information can be, for example, that the problem still occurs, that you still want the feature, that more information is needed, or that the bug is (for whatever reason) no longer relevant.

Comment 4 Michal Fojtik 2020-08-31 14:00:06 UTC
This bug hasn't had any activity 7 days after it was marked as LifecycleStale, so we are closing this bug as WONTFIX. If you consider this bug still valuable, please reopen it or create new bug.

Comment 5 Michal Fojtik 2020-08-31 15:00:45 UTC
The LifecycleStale keyword was removed because the bug got commented on recently.
The bug assignee was notified.

Comment 6 Lukasz Szaszkiewicz 2020-09-16 14:47:37 UTC
From what I have seen the test usually fails on observing a project deletion. It times out after the 30s. I have never seen a project not being deleted. It just sometimes needs more time (check below).

I'm not sure if we have an upper bound time after which the project should be deleted. Thus we could:

1. Simply increase the timeout in the test.
2. Assing to the workload team for further investigation.


https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-gcp-4.6/1306118649832017920
Timed out on STEP: waitForDelete e2e-test-project-api-67ffv
At 07:42:41.257 the test got watch.Event{Type:"MODIFIED”…} expected to see watch.Event{Type:"DELETED”…}
The ns was removed at 07:44:15.049478 (KCM) namespace_controller.go:185] Namespace has been deleted e2e-test-project-api-67ffv
Took: ~1m 35s


https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/openshift_kubernetes/350/pull-ci-openshift-kubernetes-master-e2e-gcp/1306177846674198528

Timed out on STEP: waitForDelete e2e-test-project-api-l7c8n
At 12:14:44.372 the test got watch.Event{Type:"MODIFIED”…} expected to see watch.Event{Type:"DELETED”…}
The ns was removed at 12:16:45.094049  (KCM) namespace_controller.go:185] Namespace has been deleted e2e-test-project-api-l7c8n - https://storage.googleapis.com/origin-ci-test/pr-logs/pull/openshift_kubernetes/350/pull-ci-openshift-kubernetes-master-e2e-gcp/1306177846674198528/artifacts/e2e-gcp/gather-extra/pods/openshift-kube-controller-manager_kube-controller-manager-ci-op-bhy9hy7c-b2c4f-49lg6-master-1_kube-controller-manager.log
Took ~2m


https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/openshift_kubernetes/345/pull-ci-openshift-kubernetes-master-e2e-gcp/1306174075177013249
Timed out on STEP: waitForDelete e2e-test-project-api-l869v
At 16 11:41:45.065 the test got watch.Event{Type:"MODIFIED”…} expected to see watch.Event{Type:"DELETED”…}
The ns was removed at 11:43:06.578236 (KCM) namespace_controller.go:185] Namespace has been deleted e2e-test-project-api-l869v - https://storage.googleapis.com/origin-ci-test/pr-logs/pull/openshift_kubernetes/345/pull-ci-openshift-kubernetes-master-e2e-gcp/1306174075177013249/artifacts/e2e-gcp/gather-extra/pods/openshift-kube-controller-manager_kube-controller-manager-ci-op-j7hm04zf-b2c4f-2b6qb-master-0_kube-controller-manager.log
Took: ~1m 21s

https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/openshift_kubernetes/351/pull-ci-openshift-kubernetes-master-e2e-gcp/1306053080206282752
Timed out on STEP: waitForDelete e2e-test-project-api-zf889
At 03:39:59.176 the test got watch.Event{Type:"MODIFIED”…} expected to see watch.Event{Type:"DELETED”…}
The ns was removed at  03:43:20.676274 (KCM) namespace_controller.go:185] Namespace has been deleted e2e-test-project-api-zf889 - https://storage.googleapis.com/origin-ci-test/pr-logs/pull/openshift_kubernetes/351/pull-ci-openshift-kubernetes-master-e2e-gcp/1306053080206282752/artifacts/e2e-gcp/gather-extra/pods/openshift-kube-controller-manager_kube-controller-manager-ci-op-5l1t9sch-b2c4f-94z2t-master-0_kube-controller-manager.log
Took: ~3m 20s

Comment 10 errata-xmlrpc 2020-10-27 16:08:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.