Bug 1849133 (CVE-2020-14295) - CVE-2020-14295 cacti: SQL injection in color.php can lead to remote command execution
Summary: CVE-2020-14295 cacti: SQL injection in color.php can lead to remote command e...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2020-14295
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1849134 1849135
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-19 16:41 UTC by Guilherme de Almeida Suckevicz
Modified: 2020-06-19 18:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-19 17:20:39 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2020-06-19 16:41:15 UTC
A SQL injection issue in color.php in Cacti 1.2.12 allows an admin to inject SQL via the filter parameter. This can lead to remote command execution because the product accepts stacked queries.

Reference:
https://github.com/Cacti/cacti/issues/3622

Comment 1 Guilherme de Almeida Suckevicz 2020-06-19 16:42:38 UTC
Created cacti tracking bugs for this issue:

Affects: epel-all [bug 1849135]
Affects: fedora-all [bug 1849134]

Comment 2 Product Security DevOps Team 2020-06-19 17:20:39 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.