Bug 1849148 - Cannot paste into Namespaces > Create Namespace "Labels" field
Summary: Cannot paste into Namespaces > Create Namespace "Labels" field
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Mac OS
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1850292
TreeView+ depends on / blocked
 
Reported: 2020-06-19 17:29 UTC by Jason Boxman
Modified: 2020-10-27 16:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:08:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
Valid Labels Green (79.59 KB, image/png)
2020-06-29 06:47 UTC, Yadan Pei
no flags Details
Invalid Labels Red (79.09 KB, image/png)
2020-06-29 06:47 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5801 0 None closed Bug 1849148: disable addOnPaste in <SelectorInput> 2020-08-31 18:58:08 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:08:39 UTC

Description Jason Boxman 2020-06-19 17:29:11 UTC
Description of problem:

I'm writing a procedure[0] that includes creating a namespace for an Operator. The namespace needs a label that is nontrivial to type correctly, and I found that I cannot paste content into the field.

Version-Release number of selected component (if applicable):


How reproducible:

Always.

Steps to Reproduce:
1. Namespaces > Create Namespace
2. Try to paste text into "Labels" field

Actual results:

No effect. I pasted into the "Name" field to confirm I had copied the origin text successfully, and that did work.


Expected results:

The complex label I copied pastes successfully:

```
    openshift.io/run-level: '1'
```


Additional info:

Opera beta: Version:69.0.3686.21
OS X 10.15.3

[0] https://github.com/openshift/openshift-docs/pull/22512

Comment 5 Yadan Pei 2020-06-29 06:47:28 UTC
Created attachment 1699077 [details]
Valid Labels Green

Comment 6 Yadan Pei 2020-06-29 06:47:53 UTC
Created attachment 1699078 [details]
Invalid Labels Red

Comment 7 Yadan Pei 2020-06-29 06:50:52 UTC
1. Namespaces > Create Namespace
2. Try to paste text into "Labels" field, text can be pasted now, when labels are invalid text will be in red color, while labels are valid text will be in green color, user is only allowed to paste one pair of key/value one time.

verified on 4.6.0-0.nightly-2020-06-26-035408

Comment 9 errata-xmlrpc 2020-10-27 16:08:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.