Bug 1849164 - Operators won't install if the CSV dependency is already installed
Summary: Operators won't install if the CSV dependency is already installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Evan Cordell
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On:
Blocks: 1850619
TreeView+ depends on / blocked
 
Reported: 2020-06-19 18:04 UTC by Jaspreet Kaur
Modified: 2020-10-27 16:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:08:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1589 0 None closed Bug 1849164: don't store full manifests in installplan status (for bundle images) 2020-11-30 16:20:30 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:08:39 UTC

Description Jaspreet Kaur 2020-06-19 18:04:18 UTC
Description of problem: 

We have an operator with CSV dependencies. When we install it, we expect OLM to install the dependencies as well. However, if the dependencies are already in a namespace, the operator won't install.

We have to delete the dependent operators in order to install the operator.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: Failed to install the operator because of dependencies being already installed


Expected results: Should be easily installed if it already exists.


Additional info:

Comment 6 Stephen Cuppett 2020-06-22 12:10:22 UTC
Setting target release to current development version (4.6) for investigation. Where fixes (if any) are required/requested for prior versions, cloned BZs will be created when appropriate.

Comment 13 errata-xmlrpc 2020-10-27 16:08:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.