Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1849190

Summary: Misleading log file path for Mistral in errors in update/upgrade process
Product: Red Hat OpenStack Reporter: Luke Short <lshort>
Component: openstack-tripleo-commonAssignee: mbollo
Status: CLOSED ERRATA QA Contact: David Rosenfeld <drosenfe>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 16.1 (Train)CC: jpretori, jschluet, lbezdick, mburns, rbrady, rrasouli, sclewis, slinaber
Target Milestone: gaKeywords: Triaged
Target Release: 16.1 (Train on RHEL 8.2)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-common-11.3.3-0.20200611110656.f7715be.el8ost Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-29 07:53:29 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Luke Short 2020-06-19 19:15:33 UTC
Description of problem:
One of the error messages is misleading say that we should look at '/var/log/mistral/package_update.log'. This file path on the Undercloud is actually '/var/log/containers/mistral/package_update.log'. There might not be much we can do here since it's the Mistral service in the container only being aware of the file system that is in itself (and not aware of the bind mounts). For customers, this could be confusing.


Version-Release number of selected component (if applicable):
RHOSP 13z12 to RHOSP 16.1


How reproducible:
100%

Steps to Reproduce:
1. Follow the documentation to FFU but use pre-deployed nodes.
    1a. https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/16.1-beta/html-single/framework_for_upgrades_13_to_16.1/index?lb_target=preview
2. Upgrade an Overcloud node that does NOT have the updated RHOSP 16 repositories setup yet.
    2a. openstack overcloud upgrade run --tags system_upgrade --limit overclou-controller-0

Actual results:
$ openstack overcloud upgrade run --tags system_upgrade --limit overclou-controller-0
2020-06-15 12:37:46.622 309427 ERROR openstack [-] Update failed with: Ansible failed, check log at /var/log/mistral/package_update.log.: RuntimeError: Update failed with: Ansible failed, check log at /var/log/mistral/package_update.log.


Expected results:
check log at /var/log/containers/mistral/package_update.log


Additional info:
Ignore the actual error. We had to update the repositories used by the pre-provisioned/deployed servers first.

Comment 8 Ronnie Rasouli 2020-07-19 10:36:19 UTC
found a correct log entry on failed job 2020-07-17 17:34:44 | Ansible failed, check log at /var/log/containers/mistral/package_update.log.

Comment 9 Alex McLeod 2020-07-21 11:13:16 UTC
If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field. The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Comment 12 errata-xmlrpc 2020-07-29 07:53:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3148