Bug 1849213 - clicking on Logs to view details on Pending pods cause the dreaded `Oh no! Something went wrong` error to display
Summary: clicking on Logs to view details on Pending pods cause the dreaded `Oh no! So...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.z
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1848244
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-19 20:36 UTC by OpenShift BugZilla Robot
Modified: 2020-07-16 16:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: An enhancement to preserve the selected container on on the pod Logs tab results in a `Oh no! Something went wrong` error when the pod status is pending. Consequence: Visiting the pod logs tab for a pod in with status pending results in a in a `Oh no! Something went wrong` error. Fix: Only apply the selected container fix if the user changes the container. Result: `Oh no! Something went wrong` error no longer displays for pending pods.
Clone Of:
Environment:
Last Closed: 2020-07-16 16:12:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verification screenshot (105.53 KB, image/png)
2020-07-14 03:53 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5794 None open [release-4.5] Bug 1849213: Fix bug where pending pod log tab throws error 2020-07-13 12:59:42 UTC
Red Hat Product Errata RHBA-2020:2909 None None None 2020-07-16 16:12:45 UTC

Description OpenShift BugZilla Robot 2020-06-19 20:36:25 UTC
+++ This bug was initially created as a clone of Bug #1848244 +++

Created attachment 1697902 [details]
pending pods error in UI

Description of problem:
While trying to investigate a cluster with Pending pods, by clicking on `Logs`, it bring up the `Oh no! Something went wrong` error.

Version-Release number of selected component (if applicable):

4.5

How reproducible:
When a pod is in pending state.

Steps to Reproduce:
1. Get a pod in a pending state.  The easiest way for me is to try to install metering with a cluster that has insufficent resource...worker nodes of only m1.large for example.  Will cause the presto pod to be in the Pending state

Events:
  Type     Reason            Age                   From               Message
  ----     ------            ----                  ----               -------
  Warning  FailedScheduling  4m11s (x30 over 31m)  default-scheduler  0/7 nodes are available: 7 Insufficient cpu.
2.
3.

Actual results:
Error
Description:
Minified React error #185; visit https://reactjs.org/docs/error-decoder.html?invariant=185 for the full message or use the non-minified dev environment for full errors and additional helpful warnings.
Error: Minified React error #185; visit https://reactjs.org/docs/error-decoder.html?invariant=185 for the full message or use the non-minified dev environment for full errors and additional helpful warnings. 
    at Tu (https://console-openshift-console.apps.wxj181-5422.qe.devcluster.openshift.com/static/vendors~main-chunk-19504135f53376dd474b.min.js:150:78405)
    at Object.enqueueSetState (https://console-openshift-console.apps.wxj181-5422.qe.devcluster.openshift.com/static/vendors~main-chunk-19504135f53376dd474b.min.js:150:46451)
    at t._.setState (https://console-openshift-console.apps.wxj181-5422.qe.devcluster.openshift.com/static/vendors~main-chunk-19504135f53376dd474b.min.js:142:1440)
    at https://console-openshift-console.apps.wxj181-5422.qe.devcluster.openshift.com/static/vendors~main-chunk-19504135f53376dd474b.min.js:12:98564
    at r (https://console-openshift-console.apps.wxj181-5422.qe.devcluster.openshift.com/static/vendors~main-chunk-19504135f53376dd474b.min.js:19:27428)
    at https://console-openshift-console.apps.wxj181-5422.qe.devcluster.openshift.com/static/vendors~main-chunk-19504135f53376dd474b.min.js:19:27652
    at Array.forEach (<anonymous>)
    at Object.notifyListeners (https://console-openshift-console.apps.wxj181-5422.qe.devcluster.openshift.com/static/vendors~main-chunk-19504135f53376dd474b.min.js:19:27623)
    at x (https://console-openshift-console.apps.wxj181-5422.qe.devcluster.openshift.com/static/vendors~main-chunk-19504135f53376dd474b.min.js:35:235687)
    at https://console-openshift-console.apps.wxj181-5422.qe.devcluster.openshift.com/static/vendors~main-chunk-19504135f53376dd474b.min.js:35:237265
Expected results:


Additional info:

Comment 1 Robb Hamilton 2020-06-19 20:37:32 UTC
Waiting for 4.5.z to open.

Comment 2 Robb Hamilton 2020-07-08 12:27:11 UTC
PR opened, awaiting cherry pick approval.

Comment 5 XiaochuanWang 2020-07-14 03:53:58 UTC
Created attachment 1700944 [details]
Verification screenshot

Comment 6 XiaochuanWang 2020-07-14 03:54:58 UTC
Checked on several Pendingpods, this is not reproduced.
Verified on 4.5.0-0.nightly-2020-07-13-205047
(Attached the screenshot)

Comment 11 errata-xmlrpc 2020-07-16 16:12:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2909


Note You need to log in before you can comment on or make changes to this bug.