Bug 1849244 - SDN-975 - add ovn trace to must-gather
Summary: SDN-975 - add ovn trace to must-gather
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.z
Assignee: Ben Bennett
QA Contact: Anurag saxena
URL:
Whiteboard:
Depends On: 1849243
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-19 23:34 UTC by Phil Cameron
Modified: 2020-08-10 13:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1849243
Environment:
Last Closed: 2020-08-10 13:50:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift must-gather pull 160 None closed Bug 1849244: [release-4.5]Trace ovn processing in cluster 2020-08-04 07:41:08 UTC
Red Hat Product Errata RHBA-2020:3188 None None None 2020-08-10 13:50:43 UTC

Description Phil Cameron 2020-06-19 23:34:24 UTC
Backport to release-4.5

+++ This bug was initially created as a clone of Bug #1849243 +++

Description of problem:
must-gather is extended to generate a trace of openshift-ovn-kubernetes pods.

SDN-975
https://issues.redhat.com/browse/SDN-975


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Phil Cameron on 2020-06-19 23:29:01 UTC ---

https://github.com/openshift/must-gather/pull/156 - MERGED

Comment 2 Phil Cameron 2020-07-10 12:34:50 UTC
Added:
https://github.com/openshift/must-gather/pull/159 - MERGED

So, it now generates a trace and extracts the ovn bringup items into a second file.

Comment 3 Phil Cameron 2020-07-10 14:32:18 UTC
Merging PR 160 will unblock SDN-935 and add trace of network activity to ci steps (https://github.com/openshift/release/pull/8654).

Comment 9 errata-xmlrpc 2020-08-10 13:50:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.5 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3188


Note You need to log in before you can comment on or make changes to this bug.