Bug 1849269 - [4.5] Regression: Some critical cadvisor disk metrics are not reported in 4.4 [NEEDINFO]
Summary: [4.5] Regression: Some critical cadvisor disk metrics are not reported in 4.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.0
Assignee: Harshal Patil
QA Contact: Sunil Choudhary
URL:
Whiteboard:
: 1845201 (view as bug list)
Depends On: 1831908
Blocks: 1856258
TreeView+ depends on / blocked
 
Reported: 2020-06-20 07:26 UTC by OpenShift BugZilla Robot
Modified: 2020-07-27 16:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Missing metrics for device mapper for devices Consequence: No metrics available if system was using device mapper for root device Fix: cadvisor has been fixed to report bugs even if the root device is using device mapper Result: Metrics are available irrespective of if the device mapper is used for root device or not.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:44:38 UTC
Target Upstream Version:
sdodson: needinfo? (nagrawal)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 25173 None closed [release-4.5] Bug 1849269: bump cadvisor for incorrect diskstats fix 2020-09-01 14:22:27 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:45:00 UTC

Comment 1 Stephen Cuppett 2020-06-22 15:22:26 UTC
*** Bug 1845201 has been marked as a duplicate of this bug. ***

Comment 2 Scott Dodson 2020-06-23 14:27:22 UTC
Neelesh,

The PR for this is tagged for merge. Should it not be? If it merges this bug should be 4.5.0.

Comment 6 errata-xmlrpc 2020-07-13 17:44:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.