Bug 1849340 - OCP 4.5 metadata.managedFields.fieldsType Invalid Value. Must be FieldsV1
Summary: OCP 4.5 metadata.managedFields.fieldsType Invalid Value. Must be FieldsV1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Stefan Schimanski
QA Contact: Ke Wang
URL:
Whiteboard:
: 1857655 (view as bug list)
Depends On: 1842660
Blocks: 1848437
TreeView+ depends on / blocked
 
Reported: 2020-06-20 21:34 UTC by OpenShift BugZilla Robot
Modified: 2020-08-17 20:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-17 20:05:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 25178 None closed [release-4.5] Bug 1849340: 4.6: UPSTREAM: 91748: FieldManager: Reset if we receive nil or a list with one 2020-09-01 09:24:26 UTC
Red Hat Product Errata RHBA-2020:3330 None None None 2020-08-17 20:05:40 UTC

Comment 2 Stefan Schimanski 2020-07-16 09:50:32 UTC
*** Bug 1857655 has been marked as a duplicate of this bug. ***

Comment 5 Ke Wang 2020-08-10 05:41:36 UTC
Verified with OCP build 4.5.0-0.nightly-2020-08-08-162221.
Refer to the doc : https://access.redhat.com/documentation/en-us/red_hat_advanced_cluster_management_for_kubernetes/2.0/html/install/installing#installing-red-hat-advanced-cluster-management-from-the-console, installed ACM on OCP 4.5 successfully 

After finished, checking,
$ oc project advtest
Now using project "advtest" on server "https://api.ke1051.qe.openshift.com:6443".

$ oc get csv -n advtest
NAME                                 DISPLAY                                      VERSION   REPLACES   PHASE
advanced-cluster-management.v2.0.0   Advanced Cluster Management for Kubernetes   2.0.0                Succeeded

$ oc get MultiClusterHub -o json |jq .items[0].status
{
  "currentVersion": "2.0.0",
  "desiredVersion": "2.0.0",
  "phase": "Running"
}

The ACM installed successfully as expected, so move the bug verified.

Comment 7 errata-xmlrpc 2020-08-17 20:05:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3330


Note You need to log in before you can comment on or make changes to this bug.