Bug 1849397 - [v2v][ui]VM import RHV to CNV: Import progress bar should reflect disks copy
Summary: [v2v][ui]VM import RHV to CNV: Import progress bar should reflect disks copy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Filip Krepinsky
QA Contact: Amos Mastbaum
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-21 11:42 UTC by Amos Mastbaum
Modified: 2020-10-27 16:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:08:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
Progress Bar (47.32 KB, image/png)
2020-08-11 07:38 UTC, Amos Mastbaum
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:08:39 UTC

Description Amos Mastbaum 2020-06-21 11:42:40 UTC
Description of problem:
when running VM import from RHV to CNV, the progress bar displays the VM import progress 10% right from the start.
This reflects the VM import process/request progress phase, while it should actually reflect disk copy progress. This may confuse the user, as seeing 10% looks like 10% of the disk was copied.



Version-Release number of selected component (if applicable):


How reproducible:
It is always reproducible, but a disk import operation should be long enough to be notable.



Steps to Reproduce:
1.Using the OCP CLI or the GUI create a machine by importing a RHV VM with a very large disk from a remote location. 
2.In the OCP GUI, Workloads -> Virtualization, click on the machine's status (Importing (RHV))


Actual results:
The Status indicates it is Copying a disk and the status bar remains on 10% during the entire operation.



Expected results:
Status bar present should/also reflect the disk copy operation progress (how much of the disk was copied/imported).


Additional info:

Comment 2 Amos Mastbaum 2020-06-30 06:38:45 UTC
@Piotr how to a check the cdi version?

Comment 3 Guohua Ouyang 2020-06-30 07:32:09 UTC
(In reply to Amos Mastbaum from comment #2)
> @Piotr how to a check the cdi version?

Hi, I use the methond below to get the cdi version:

$ oc get pod -n openshift-cnv | grep cdi-apiserver
cdi-apiserver-57b469b699-8c294                        1/1     Terminating        0          29h
cdi-apiserver-57b469b699-h9grh                        1/1     Running            0          133m

$ kubectl exec cdi-apiserver-57b469b699-h9grh -n openshift-cnv -- virt-cdi-apiserver --version
Containerized Data Importer v1.18.1

Comment 4 Tomas Jelinek 2020-07-10 06:54:11 UTC
There has been a big batch of v2v related bugs moved to kubevirt plugin at once. We are working on them but due to capacity this did not make it last sprint.

Comment 6 Filip Krepinsky 2020-08-10 16:55:41 UTC
@Amos does the progress get updated when using the newest CDI?

Comment 7 Amos Mastbaum 2020-08-11 07:38:29 UTC
Created attachment 1711042 [details]
Progress Bar

The UI remains on 10% while the dv is in progress:

$ oc get dv -n amos
NAME                                                PHASE              PROGRESS   RESTARTS   AGE
v2v-rhel8-vm-380dc04a-b9d5-4c37-9038-d3e9baf75ce9   ImportInProgress   5.48%      0          52s
[amastbau@amastbau notworking]$ oc get dv -n amos
NAME                                                PHASE              PROGRESS   RESTARTS   AGE
v2v-rhel8-vm-380dc04a-b9d5-4c37-9038-d3e9baf75ce9   ImportInProgress   5.92%      0          55s
[amastbau@amastbau notworking]$ oc get dv -n amos
NAME                                                PHASE              PROGRESS   RESTARTS   AGE
v2v-rhel8-vm-380dc04a-b9d5-4c37-9038-d3e9baf75ce9   ImportInProgress   6.67%      0          63s
[amastbau@amastbau notworking]$ oc get dv -n amos
NAME                                                PHASE              PROGRESS   RESTARTS   AGE
v2v-rhel8-vm-380dc04a-b9d5-4c37-9038-d3e9baf75ce9   ImportInProgress   7.05%      0          68s
[amastbau@amastbau notworking]$ oc get dv -n amos
NAME                                                PHASE              PROGRESS   RESTARTS   AGE
v2v-rhel8-vm-380dc04a-b9d5-4c37-9038-d3e9baf75ce9   ImportInProgress   7.21%      0          71s
[amastbau@amastbau notworking]$ oc get dv -n amos
NAME                                                PHASE              PROGRESS   RESTARTS   AGE
v2v-rhel8-vm-380dc04a-b9d5-4c37-9038-d3e9baf75ce9   ImportInProgress   7.38%      0          73s
[amastbau@amastbau notworking]$ oc get dv -n amos
NAME                                                PHASE              PROGRESS   RESTARTS   AGE
v2v-rhel8-vm-380dc04a-b9d5-4c37-9038-d3e9baf75ce9   ImportInProgress   7.63%      0          77s
[amastbau@amastbau notworking]$ oc get dv -n amos
NAME                                                PHASE              PROGRESS   RESTARTS   AGE
v2v-rhel8-vm-380dc04a-b9d5-4c37-9038-d3e9baf75ce9   ImportInProgress   8.35%      0          84s
[amastbau@amastbau notworking]$ oc get dv -n amos
NAME                                                PHASE              PROGRESS   RESTARTS   AGE
v2v-rhel8-vm-380dc04a-b9d5-4c37-9038-d3e9baf75ce9   ImportInProgress   8.64%      0          87s
[amastbau@amastbau notworking]$ oc get dv -n amos
NAME                                                PHASE              PROGRESS   RESTARTS   AGE
v2v-rhel8-vm-380dc04a-b9d5-4c37-9038-d3e9baf75ce9   ImportInProgress   15.53%     0          2m31s

Comment 8 Amos Mastbaum 2020-08-11 07:42:51 UTC
It is cnv 2.4.1

Comment 9 Filip Krepinsky 2020-08-11 11:02:41 UTC
ah okay, so the CDI is working. 

Can you post VirtualMachineImport resource? Does the progress annotation get updated?

oc get -w virtualmachineimports.v2v.kubevirt.io -o custom-columns="NAME:.metadata.name,PROGRESS:.metadata.annotations.vmimport\.v2v\.kubevirt\.io/progress"

Comment 10 Amos Mastbaum 2020-08-11 12:11:48 UTC
Verified again.it is working correctly!

Comment 13 errata-xmlrpc 2020-10-27 16:08:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.