Bug 1849441 - Update pkg-config file if renaming gio-querymodules
Summary: Update pkg-config file if renaming gio-querymodules
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-21 18:04 UTC by Jehan
Modified: 2020-07-08 01:05 UTC (History)
9 users (show)

Fixed In Version: glib2-2.64.3-2.fc32 glib2-2.62.6-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-24 01:01:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Jehan 2020-06-21 18:04:06 UTC
Description of problem:

The dev tool `gio-querymodules` is renamed to `gio-querymodules-%{__isa_bits}` (e.g. `gio-querymodules-64`) in Fedora manifest. Cf. https://src.fedoraproject.org/rpms/glib2/blob/master/f/glib2.spec#_120

This breaks builds of applications depending on this tool (for instance GTK) if they expect to find it as `gio-querymodules`. This was reported to upstream Glib (specifically for the Fedora change; which I also encountered) which added some variables inside the GIO pkg-config file. So instead of searching for the binary in PATH, projects are now encouraged to look for the result of:

> pkg-config --variable=gio_querymodules gio-2.0

Glib bug report: https://gitlab.gnome.org/GNOME/glib/-/issues/1796
Glib patch: https://gitlab.gnome.org/GNOME/glib/-/merge_requests/881

Now main thing missing is for Fedora to edit the `gio-2.0.pc` file if you continue modifying the tool name.

Version-Release number of selected component (if applicable): I encountered the issue in `glib2-2.62.6-1.fc31.x86_64` from Fedora 31, but since I see the RPM manifest is still changing the tool name while not editing the `.pc` file, then I assume the issue still exist in Fedora 32 or rawhide.


How reproducible: always


Steps to Reproduce:
1. Run:

> pkg-config --variable=gio_querymodules gio-2.0 

Actual results:

> /usr/bin/gio-querymodules

Expected results:

Because Fedora manifest renamed the tool to `gio-querymodules-64` on Fedora 64-bit, the command should return:

> /usr/bin/gio-querymodules-64

Additional info:


Just edit the manifest `/usr/lib64/pkgconfig/gio-2.0.pc` so that:

> gio_querymodules=${bindir}/gio-querymodules

becomes:

> gio_querymodules=${bindir}/gio-querymodules-64

A simple `sed` after `%meson_install` in the RPM manifest would do the trick.

Comment 1 Kalev Lember 2020-06-22 10:58:20 UTC
Thanks, I went ahead and did that in https://src.fedoraproject.org/rpms/glib2/c/ee2a2469250537587f29a86e23819b6d716193ea?branch=master

Comment 2 Jehan 2020-06-22 11:04:51 UTC
(In reply to Kalev Lember from comment #1)
> Thanks, I went ahead and did that in
> https://src.fedoraproject.org/rpms/glib2/c/
> ee2a2469250537587f29a86e23819b6d716193ea?branch=master

Awesome thanks!

Comment 3 Fedora Update System 2020-06-22 11:17:22 UTC
FEDORA-2020-c63aad4d16 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c63aad4d16

Comment 4 Fedora Update System 2020-06-23 01:04:59 UTC
FEDORA-2020-c63aad4d16 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-c63aad4d16`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c63aad4d16

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-06-23 01:54:27 UTC
FEDORA-2020-b5e0041373 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b5e0041373`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b5e0041373

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-06-24 01:01:00 UTC
FEDORA-2020-c63aad4d16 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2020-07-08 01:05:24 UTC
FEDORA-2020-b5e0041373 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.